Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unknown lifecycle phase error

I am getting Unknown lifecycle phase error after entering the command

atlas-mvn eclipse:eclipse

Screenshot (1).png

Can anybody help me with this? 

4 answers

@Vlad Polonskiy  Thanks a lot :)

changed to "call set MVN_COMMAND=%%MVN_COMMAND:%%"

Build is success now.

2 votes
Andy Heinzer Atlassian Team Feb 15, 2019

It looks like this kind of error has been reported before when using the Atlassian-SDK on Windows platforms specifically.  Please see the bug report in https://ecosystem.atlassian.net/browse/ATLASSDK-93

In it, other users have reported in the comments there that it might be possible to modify a mvn.bat file in that bin folder and make some adjustments to avoid this error.   I'm more concerned about the first error on the screen after you run your command of:

'else' is not recognized as an internal or external command,
operable program or batch file.

Perhaps if we can address that issue first, these other errors can be avoided entirely.

Looks like I was able to fix "Lifecycle Phase" error as follows (I got it on Windows):

1. In "atlas-mvn.bat" file comment out the following line:

call set MVN_COMMAND=%%MVN_COMMAND:${mavenPluginName}=%MVN_PLUGIN%%%

2. Replace it with:

call set MVN_COMMAND=%%MVN_COMMAND:%%

Vlad

Like # people like this

Many thanks this solve the issue I was having :)

Thanks again

thanks - fixed my eclipse error

 

else is here but I'm not sure how to fix

:loopstart
set /a ARGI = !ARGI! + 1
set /a ARGN = !ARGI! + 1

if !ARGI! gtr %ARGC% goto loopend

call :getarg !ARGI! ARG
call :getarg !ARGN! ARGNEXT


else (

set MVN_PARAMS=%MVN_PARAMS% %ARG%
shift
goto loopstart

)
:loopend

Many thanks @Vlad Polonskiy! After updating SDK I've been stuck for several hours with "Lifecycle Phase" error. Your comment contains must-have info to fix it.

Like Sam likes this

This is entirely unacceptable. Why has the SDK not been updated to fix this wide-spread issue?

Atlassian's priorities over the last couple years have been atrocious. They need to gets their shit together. People are already talking to their C-levels to convince them to leave Atlassian products.

You make products for developers, but ignore developers.

Developers like text-based editors, so Atlassian is removing text-based editing across all their products. It's already gone from confluence, bitbucket is currently in transition (hit the feedback button and complain! please!), and Jira will likely be next (I don't use Cloud, so not sure about there).

Developers like using code blocks. Atlassian has had several issues dating back a decade to allow code blocks to be indented. Nothing. Some of their products don't even allow inline code blocks. It's absolutely ridiculous.

 

What happened to no sales/marketing? Oh, yeah, you went public in 2015. That explains a lot. Everything Atlassian is doing these days is geared toward non-technical users - the same users that sales/marketing would be approaching to sell the products to. In the past, developers chose to use Atlassian products because they were good and pushed it up the chain. They are reversing this process and it is resulting in developers being pushed away from the products.

 

A simple google search for "alternatives to atlassian" shows numerous articles from 2019 listing their top alternatives. Some as recent as a few days ago. The tides are changing. People are looking elsewhere.

Like # people like this

`atlas-mvn clean` still fails with "No goals have been specified for this build." Might fix the goals with format eclipse:eclipse, but it doesn't work with singular commands. You can use the atlas-* scripts for most of them, but not all. Still not 100%, but enough to actually get working.

@Vlad Polonskiy Vlad's solution worked for me and should be posted as the answer.

Like Sam likes this

Cant seem to find the bat file?  Where would the bat file be in the folder structure?

Like Sam likes this

Hi @oliverbriansyson , it would be in "bin" folder (%ATLAS_SDK_HOME%\bin):

Image 1.png

Like # people like this

@Vlad Polonskiy Thanks for commenting, it fixed it for me!

@Leirbag_Assuab Thanks for specifying where the bat file is!

Thanks for this, I can't believe it is still an issue, over a year now.

A year?! Ha!

"November 4, 2015" is when the issue (https://ecosystem.atlassian.net/browse/ATLASSDK-93) was created.

Like John Lill likes this

Unbelievable. Fits well in the general loss of Atlassians connection to users and developers. I am sorry to see that development still ongoing.

Thanks for the fix, Vlad. Should have been provided by Atlassian a long time ago.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you