Unable to set Due Date on Issue

Tried this on a few issues in a sample project and a new project with a new issue.

All the fields on the right hand side can be edited with the exception of due date. If I clicked over the grey text 'None' it doesn't do anything at all. I've tried in Chrome and IE and I cant set it in either. 

Am I missing something? Does it rely on another field being set first?

Thanks

3 answers

1 accepted

Accepted Answer
3 votes
Alexey Matveev Community Champion Jan 03, 2018

Hello,

The duedate field must be added to the edit screen for the issuetype and the user must have the schedule issues permission.

Alexey Matveev Community Champion Jan 03, 2018

Click the edit button and see if the duedate on the edit screen

Can't see the Due Date field on the edit screen.

Ok, think I got there.

Added the 'Due Date' field to the 'Default Issue Screen' Screen configuration. Now when I pull up the issue and click 'Due Date' it shows the calendar.

Thanks for your help!

@Maurice Thompson's solution worked for me. Thanks!

This is it indeed! Thanks!  (found after two hours of searching and trying stuff)
If you're not sure, thick al those boxes...!

We did all of this, and no Due Date option appears. We set permissions for any administrator to Schedule Issues. Yet, no option for Due Date is available to us. Time tracking is there, but that doesn't allow us to set a Due Date. What should we do? 

Go into edit the issue in full, then look to the top right of the window for "configure fields".  In that menu, there should be a "where is my field" option.

This should list all the reasons that a field might not appear, flagging any that are blocking it with a cross and a link to what needs to be changed to make it work.

Hello,

Please check the permission scheme of the project and then the Schedule Issues permissions. Your user / group must have permission to change the Due Date

The permission scheme looks like the default ...

Schedule Issues

Ability to view or edit an issue's due date.

Project role

- atlassian-addons-project-access

Application access

- Any logged in user

I created the project and I'm the administrator. I even added the site-admins group to the schedule permission above, logged out and logged back in and still nothing when I click on 'None' under Due Date.

Any ideas?

Thanks

This is a trial by the way, just set it up today. Could the field be disabled in the trial period?

Thanks

Alexey Matveev Community Champion Jan 03, 2018

No, it can not be disabled

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

29 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you