Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to save a jira ticket because of formatting issue Edited

7/23/2019 Update

I am updating this and have unaccepted the original suggestion, hoping that we can get more attention from Atlassian to address this issue. I still run into the same issue from time to time, here's how I avoid/troubleshoot to overcome this while we await Atlassian to address it.

1) Do not add images, tables, or any other more complex stylings on the "Create Issue" modal. Do these things after you create the issue.

2) Avoid having a super long issue.

3) Avoid using markdowns for text stylings, use the text editor.

4) When running into this issue, deal with images, tables, and links first.

5) If all things fail, copy and paste into another new jira ticket.

6) I've also upvoted the posts that have shared how they get around the issue that might be helpful to your situation.

Reminder: we all get frustrated with things that slow us down, but it's not an excuse to be rude and unprofessional. Please do continue to share your experiences with this issue and how you get around it.

thx.

 

Original Post from 4/18/2019

An error message occurs while I am composing a jira ticket:

"We couldn't save your content. It may contain formatting we don’t recognize. Try removing the formatting before saving."

How do I troubleshoot for this?

 

Screen Shot 2019-04-18 at 12.44.01 PM.png

 

16 answers

JIRA Team.. THIS IS THE DUMBEST SHIT I HAVE EVER SEEN!!!!!!!!!

What was ONCE a TOOL.. is now a POS.

 

My God.. I cant BOLD TEXT with my keyboard.. and Ctrl REturn?? 

Like # people like this

Unfortunately, I am copying the text from word without formatting and I am formatting the text on the text editor on the Issue. Still no hope, it doesn't allow saving. It is difficult to handle this situation all the time while creating an issue. Expecting more freedom on this editor.

Monique vdB Community Manager Aug 26, 2019

@nigelgilbert abusive language (aka name-calling) is against our terms of use. I hear you're frustrated and we'll try to get an answer for you, but maybe take a step back until you can express your frustration in a more constructive way. 

Like # people like this

While I wouldn't have used swear words in a public forum like this, I certainly appreciate the frustration.  I just ran into the same issue and it took me a while to figure out that I could select the entire description, copy it, replace it with "test", save, then paste the description back in  and save.

Speaking as a software developer, I'd be horrified at this bug and would be working extremely hard to fix it, even if that meant pulling all-nighters. It is an embarrassing bug.

Like # people like this

Yooo, I seem to have found a workaround by using FireFox.

Somehow it automatically adjusts my content so it is saveable.

Jira does this all the time.

It's straight up a deficiency in the product.

I am very annoyed that a simple copy-paste of another ticket results in this garbage error.  Unfortunately I have to use these comments for work.

This is a bug.

@Mei Chen Try to find out if there are any weird unacceptable characters or links in Text-based fields like Summary, or Description. etc., remove them and see if you are able to create the ticket.

Ridiculous suggestion, Jira doesn't point me in any direction here, so I'm trial and error removing items and clicking Save to no avail.

Like # people like this

What are the "unacceptable characters" ?

Is there a maximum of "all types of" characters for one cell of a tab ? For the whole table ?

Is there any rule about bullet lists in a table which could cause a saving error ?

Currently we have to use the old version of Jira to be able to save our content in our table but soon this won't be possible anymore...

 

Where are the formatting rules published ?

Regards

This bug really annoyed me after I had invested a lot of time in formatting and writing content. The error just washes all the stuff you have done. 

This generally happens when you do a paste a formatted text (even from other JIRA tickets). 

A workaround to this until it gets solved can be:

Duplicate the tab and edit the description. With the new view of JIRA, you would mostly get the unsaved content that couldn't get saved. The only extra thing is that you can now see 'Unsupported content' in the post. Just delete it and save. Viola! 

Hi, 

 

Thanks for the workaround but I'm not sure I understood it precisely.

If I duplicate the tab and edit the description and try to save I get the error message saying it's not possible to save because of the format... If I close this error message The table is in edit mode and I can only save it --> not possible or cancel the changes...

I'll try to summarize it into steps. Basically, you need to look for 'Unsupported Content' in the description now.

  1. Duplicate the tab. You can also refresh the same page. But this is recommended so that you don't loose your work if it doesn't get drafted. 
  2. In the duplicate tab, try to edit the description. Wait for a second or two and you should see the unsaved changes now.
  3. In most cases, you should see a text in a grayscale snippet 'Unsupported Content'.
  4. Simply delete this snippet with backspace. 
  5. Do this for all of these. 
  6. Try to save now. 

I'm on the go at the moment. I can easily replicate the issue and will attach the screenshot showing that 'Unsupported Content' snippet once I get on my laptop.

Do let me know if it doesn't work or I need to explain more. 

I don't have the snippet for my changes :(

but Still can't save without the error message about the format (the table was created in the older version), changes are made in the newer version of Jira.

Actually, my workaround was regarding the error when you copy paste formatted text from another source.

In your case, have you tried first saving it in the older view (by appending ?oldIssueView=true to the JIRA URL)? Then you can remove the parameter in URL to see the changes in newer view. 

Yes this is our workaround currently :)

But what will happen when it will no longer be possible to access to this older view ?

I've been slowly migrating all my tables to new view and then formatting them in the new view only. Also, there's an unsolved bug regarding this so I think they may come with a resolution before going aways with the older view. 

Like Camille Puisais likes this

This is a bug - imagine having JIRA suggesting formatting only to be told by JIRA that it can't save it.

I copied the entire description, replaced it with "test", saved, then pasted it back in and hit save again.  YMMV, but if I save anyone else precious time in their lives working around this obnoxious bug, I'll be satisfied.

Thanks, I'll try if I ever get the trouble again

This is essentially how I got it working. I didn't replace the whole description, though. Here is what I did:

  1. Click in the ticket description to get to Edit mode
  2. Copy the entire description with Cmd+A Cmd+C (Mac shortcuts)
  3. Paste the description into a text editor to make sure it copied correctly (thank goodness I did this step!!). The entire text wasn't copied, only the first few lines. No matter how many times I selected all and copied, it would only paste up to a point. That point seemed to be where the formatting problem was.
  4. Just select, copy, and paste the problematic section of the ticket description. You may have to do it in parts if it won't let you copy the entire section.
  5. Once you remove that section by deleting or cutting it, you can now format and edit the ticket as you see fit and it will save. Paste back the problematic section from your text editor.

Is there an open ticket for us to state that we are affected customers because of this bug?

I'am also facing the same problem. Help!

I have lost so many hours thank to this stupid bug. This is unacceptable in a paid software!

Like Andrei Muravlyov likes this

@Taranjeet Singh _Cprime_ Thank you for your response.

Here's the issue: unacceptable link.

Here's how I troubleshoot: I have some text in different colors, so what I did first was to reset all text color back to the default black/grey. That's when a blue link text surfaced. Apparently a previously deleted @mention tag inline effected the text that follows. Also for some reason any @mention tag that I used would trigger the same error.

Consider issue resolved. thx.

@Mei Chen If my answer helped resolving your issue, please mark it as acceptable.

Had the same issue - was caused by having bold text in ticket description?!?!

I have no special characters aside from CODE.  "@VariableName" is valid code in many languages, so if it's having issues with accepting the @ character inside of a <CODE> section, then it's a BUG on Atlassian's side that needs to be fixed.  This is ridiculous that I can paste code in some tools and not others (or, not in comments).

@Chris Norman , so this issue happened to me again and took me a long time to debug last week. I am not sure what the character limit is for the description field, but it might be another reason when the issue is too long. Another way I overcome this was to copy and paste into a brand new jira issue, it works even though I didn't make any changes. 

This is the Straight up dumbest shit I have EVER encountered.  

 

This is how software goes.. its great.. its great.. then money is made.. and then it TURNS TO SHIT...

 

Welcome JIRA to the next version of Good to Crap.

 

I have to Copy and Paste the content of a ticket to Notepad FIRST?

 

YOU PEOPLE ON THE JIRA DEV TEAM ARE NOT PRODUCT MAKERS

YOU ARE PRODUCT FAKERS

 

Quit!!!

Like # people like this

This error message is also shown when writing Shift + Return, which you usually would use to add an extra line in a list, which belongs to the same list item

 

  1. First item
  2. Second item
    Shift + Return to add an extra line to the second item  <-- This doesn't work in issues any more
  3. Third item

Hmm I can't reproduce that anymore. Ignore for now.

I was able to get around this issue by switching back to the old view (there should be a link if you scroll up to top of the page in Jira) and I then I was able to use the old code snippet feature which still works.

I will add that I've been disappointed in Jira lately. They have been rolling out a lot of new features and UX changes, which feel like they are poorly tested and are unleashed on users without warning. The experience of using the product has been getting worse & I am not sure what they are trying to accomplish, but it would be nice if they slowed down and thought about their existing user base rather than give you a new UX every week.

Hi, 

Yes indeed but until when this link will be available?

And switching back to the new view causes unwanted modifications in the table...

I noticed this in Chrome today (Version 79.0.3945.130).

Tried it in Firefox (73.0.1) and it worked like a charm.  Maybe that's another 'workaround' to use FF.

Perhaps the following browser console error will help identify and fix the issue:

tslib.es6.js:71 Uncaught (in promise) Error: The call did not succeed after 1 attempts. Last error is
---
Error: Got error code 403: {"error":{"code":"JwtAuthoriser:AuthorisationError","title":"The token does not allow requested operation. \"urn:filestore:file:dfce0413-ff20-49dc-a1ca-568a17a8f586\" needs \"read\" permission","href":"https://api.media.atlassian.com#UnauthorizedError"}}

its one of the most annoying things in Jira. I can't deal with copy and paste problems, I lost a lot of time because of this.

 

with all big companies like Jira... I just don't understand what you are doing sometimes... there are errors all over... you are big multi milion company just don't understand why there are some crucial bugs like that

 

idiotic bugs by multi milion company... just don't understand ...how such company with such funding can generate such dumb issues that are all over all apps

 

[Personal attack removed]

Monique vdB Community Manager Mar 10, 2020

@Fin Systems Ltd_ hi there, I removed some content from your post that was in the form of personal attacks, which are not allowed on this platform. Please be mindful of this going forward and keep your criticism constructive. Thanks!

Monique, instead of policing the forums, get this bug fixed. Its just not acceptable, I've lost countless hours due to this shit.

I was getting this error when trying to insert an image into a Ticket. Even if there was nothing in the ticket.

All the images I tend to upload are screenshots, and they have a colon (:) in their filename. This was proving to be the issue. 

If I change : to _ in the image filename, then it works without issue.

I only worked this out because I turned off the "New Issue View", tried to upload the image, and actually got a helpful error message, instead of "We couldn't save your content. It may contain formatting we don’t recognize."

tl;dr Couldn't upload images that have a colon (:) in their filename.

I am having a similar issue currently with our system and have spent HOURS resolving to find that JIRA will not create ticket from the helpdesk portal or email if it contains the word:

"having"

Anyone else run into this issue?

Hi,

I do not experience your issue, however have you considered to try using FireFox? Every issue I have had with JIRA seems to be resolved that way.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you