Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to parse created date

I am attempting to import data from a csv file using the import wizard.  I have a field for Date Created and Date Resolved. The excel format is dd/MMM/yy h:mm a and in JIRA the format is setup as dd/MMM/yy h:mm a.

I keep receiving the following error each time I import:

2015-04-10 15:29:14, 990 WARN - Unable to parse created date 31Mar/15 9:00 a

2015-04-10 15:29:14. 990 WARN - Unable to parse created dateStr 31/Mar/15 9:30 a

I have tried several different date formats (made sure the JIRA and excel formats matched) and I get the same parsing error each time.

Any suggestions?

 

5 answers

0 votes

Hey Youmna,

Please take a look at the second question of this article: https://confluence.atlassian.com/display/JIRA/Commonly+Asked+CSV+Questions+and+Known+Issues

 

Regards,

Arthur Gonçalves

Arthur,

I made sure the date from the configuration file matches the date coming from the csv file.

It states that "JIRA system date fields such as Created, Updated, and Due Date use "yyyy-MM-dd HH:mm:ss" but may need an offset adding.  I tried this format and still received the parsing error.  How do I ad an offset?

See screenshots below on configuration:

date picker.JPG

 

look and feel.JPG

Did you ever find an solution to this? I'm having the same problem.

Anyone ever figure this out - i have tried multiple date formats both in JIRA and in excel - anytime i import it cannot parse the date.  

I am facing the same issue, i have tried multiple formats, any solution to this problem?

I tried the following steps and it's worked for me.

  1. Find the date format used in the csv file by opening it in notepad/notepad++. Because the format displayed in csv is "05/26/2020 02:41 PM" but when I opened in notepad the format displayed is 05/26/2020 14:41".
  2. During the setup phase of the import process, just mention this format (mm/dd/yyyy hh:mm) in the Date Format field.
  3. Doing so, imported the date fields properly without any warning.

Note: On seeing the format in csv I used "mm/dd/yyyy hh:mm a" in the Date format field during my first import and I got the same warning "Unable to parse date".

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you