Unable to migrate data from standalone jira server to either cloud or another standalone server

I'm afraid I'm circling the drain on this one. I'm hoping that in describing this, someone will point out the obvious thing I've missed.

 

Start with an old 6.5?? Standalone JIRA server. I upgraded to the latest 7.61 and everything works fine on the original set of data and upgraded instance. 

Next step was I created an AWS instance of Ubuntu 16.04 and created the database according to the documentation (confluence database setup https://confluence.atlassian.com/doc/database-setup-for-mysql-128747.html,  Jira db setup https://confluence.atlassian.com/adminjiraserver071/connecting-jira-applications-to-mysql-802592179.html

I ran the installer atlassian-jira-software-7.6.1-x64.bin and it seemed to install okay. I installed mysql-connector-java-5.1.45-bin.jar before starting up JIRA.

I started up JIRA and went through the initial configuration. I've tried two different paths of importing my dataset and both fail. The early import seems to complete without any errors but I can't login. My administrative account does not respond to either the password I set it to in the initial configuration or the password that is theoretically stored in the database.

If I  configure the JIRA environment by itself, it works fine I can create projects but when I go to import my old data set from the administrative panel, it gives me some error about missing object types. Unfortunately I didn't capture the error  and I'm too tired to go and create it yet again.

My next thought was that maybe I'm doing something  wrong in the install. What if I use a "known good" instance of JIRA in the cloud. I create a freebie account try to import my data and this time I can login, I can see other users but all of my projects kanban boards everything is gone.

I am out of ideas. I've been fighting with this for way too long and I've gone through a number of official and unofficial bits of documentation and nothing works. I'm clearly missing something but I can't see it anymore. Any ideas on what to look for would be greatly appreciated.

--- eric

 

 

1 answer

0 vote

On the "missing password" problem - you were entering user credentials from the system you were restoring from right?  The system import brings in the old user accounts, overwriting the ones you set during install/config of a bare system.

There's not a lot we can do without knowing what the "missing object types" being reported is.

thanks for the reply. 

Yes, I did use the password/credentials that I use to log into the original system. When I imported the same database to the cloud-based JIRA, I was able to login with those credentials. The new server instance would not let me login.

So I'm left with cloud-based JIRA, can login but none of my data is visible, server-based JIRA, import seems to work okay, I can see data in the database but I can't login.

What tables in the database would contain these credentials? Is anything the log that might give me a clue to a database problem?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

344 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you