Unable to link to Google Doc in JIRA - null pointer exception error

I'm testing out the Google Drive (and Docs) in JIRA plugin from Appfusion. The plugin is installed and licensed for the 30 day trial. I have entered in the same authorization details for this plugin (the Oauth and Consumer secret) that are working successfully for the Confluence version of this plugin.

In a JIRA issue, when I go to More Actions > Link Google Document, I am take to the Google Docs Picker, which has this message: "JIRA is currently not authorized to retrieve data from Google on your behalf. Please click this link to authorize access." When I click the link, I am taken to a Google Accounts page where I can Grant Access or Deny Access. If I click on Grant Access (or even Deny Access), I get an "Oops - an error has occured" page, with the error message that is attached. (JIRA_null_pointer.txt)

From looking at the error, I see some mentions of the two step authentication. I know that I didn't need that for the Confluence version of this plugin. Is that my issue here, or is that not relevant?

Any assistance would be appreciated.

5 answers

1 accepted

Accepted Answer
1 vote

Found no answer to this. Uninstalling the plugin.

Alan -

Answers is not our support channel, even though we try to watch it also - info@appfusions.com works, as recommended in other comments - as well as our phone number (888-516-2890) shown on the front of our website.

We have this plugin deployed to many customers.

We are sorry your expectations of plug and play are not being met here - but integrations are complicated sometimes, especially if there was a misconfiguration at some point in the initial install or configuration -

Obviously, there is something not configured right still, but I assure you that this plugin works, and works well.

But to be fair, you need to give the vendor a chance by contacting them directly - I think that is reasonable.

Please contact me personally at ellen@appfusions.com so we can get a screenshare and get you going, if you wish. Again, this is deployed to many customers, without complaint.

Ellen

Ellen,

Per your earlier reply on 28 October, I sent a message to info@appfusions.com on 29 October at 1152 EDT, with my log file attached, and a description of the problem, and noted that I was doing this at your request. I did not receive a reply. So I did contact the vendor directly, which, as you say, was reasonable.

I have no doubt that this works for many customers, but it did not work for me. I was also not expecting "plug and play" - I had to manually install the SWFTools on the server from the CLI to get the Confluence version of this working, and am no stranger to spending hours at the command line parsing log files and fighting dependencies. I had to do that to get SWFTools installed, in fact.

At this point, we will continue with the Confluence version of this plugin, which we will be purchasing a 25 user license for in the next few days. We will hold off working on any JIRA integration for the time being, and come back to that at a later date if needed.

Alan

Sorry for the delay Alan -

Just saw this question now. You can always catch us directly at info@appfusions.com

Anyways, did you get this resolved?

The first time a user must authenticate - and will hold for subsequent sessions until you revoke that authentication. A shortcut is to go to your User Profile, and click on the "Google" to authenticate.

(and also to revoke later if you wanted to - toggled)

Let me know if you still have any troubles.

Best,

Ellen
ellen@appfusions.com

Ellen,

Thanks for the reply, but no, that doesn't resolve the issue. All that does is take me to the same screens, and gives me the same error.

Hello Alan -

Can you tell me what versions you are running - both JIRA and the plugin?

I am not sure what the problem is on this alone since we have deployed this successfully to many customers, but maybe there is a plugin conflict or something going on.

We can certainly get this running for you - will you provide your Support logs to info@appfusions.com, or we can get a quick gotomeeting to review your system and get you going on the fly.

Looking forward to hearing from you -

Best,

Ellen
ellen@appfusions.com

Ellen,

I'm running JIRA 5.1.3, and the plugin version is 2.0.1. I've just submitted the support log and the text from the error message to the e-mail address you provided above. Please let me know if you need more information.

Thanks

Alan

Hi Alan,

There are 2 possible causes for this, which you can check and verify.

#1, make sure your JIRA host server's time setting is properly synced. Communication with Google is secured to prevent tempering of data going between JIRA and Google, so if your JIRA server's time is not synced correctly (if it is a few seconds ahead or behind), Google will consider someone has tempered with the connection request.

#2, double check your Google OAuth consumer key and secret. Be careful of trailing white spaces.

Hopefullly this will help you with your problem.

Regards

Patrick

I deleted and re-added the Google OAuth key and secret. Still getting the same error. The time is about a minute off, but... this is on the same server that has our Confluence install, and the plugin is working properly there. Would the time being off affect one and not the other?

I'll install and configure NTP on the server and sync to our local clock, and test again.

Added ntp, set it to our local clock, and the time is correct. Removed and readded the details from Google, and I still get the same null pointer exception error.

The plugin works in Confluence, using the same Google account details, and on the same server.

Please let me know if I need to supply any further info.

Pls write me at Ellen@appfusions.com to schedule a screenshare review of your system so we can solve your problem. This thread is not productive any longer.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

456 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you