It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to install service Edited

Hello Comunity,

I've upgraded jira to 8.4.1 but now it wont start.

I've tried to remove install the service with the cmd on the bin but when i try to install it it just says

Installing the service 'JIRASoftware240519150025' ...
Using CATALINA_HOME: "C:\Program Files\Atlassian\JIRA"
Using CATALINA_BASE: "C:\Program Files\Atlassian\JIRA"
Ignoring JAVA_HOME: "C:\Program Files (x86)\Java\jre1.8.0_211"
Using JRE_HOME: "C:\Program Files (x86)\Java\jre1.8.0_211"
Using JVM: "C:\Program Files (x86)\Java\jre1.8.0_211\bin\client\jvm.dll"
Failed installing 'JIRASoftware240519150025' service

-Already tried:

  • Remove spaces from dir in entorn variables as progr~1(x64) or 2(x86)
  • Change to the x64 program files
  • Also I remembered that in other ocasion I managed to open some tomcat config tool from the command prompt at the bin dir wich let me choose the JVM to use and that way it started but if I click on tomcat it just says Not service installed as "tomcat8" more or less. EDIT(https://support.eset.com/kb5550/) I remembered setting the JVM like that in order to solve it when it happened time ago, but when i start tomcat8w.exe it says its not an installed service 'tomcat8' ./EDIT

Our Jira pre-prod server is placed on a Virtual Machine with Windows 10

Any help would be appreciated

 

4 answers

1 accepted

0 votes
Answer accepted

After several tries, I sorted it out by test-error debugg on setting up Java and the JRE and JDK. But this happening after each upgrade is annoying

Hi, 

Let me know how you're installing JIRA service on windows. You can check the below link on how to install it manually.

https://confluence.atlassian.com/adminjiraserver/running-jira-applications-as-a-windows-service-938847902.html

Alternately, if you encounter any error - provide the logs from event viewer for debug

 

-Shankar

Hi Shankar,

Thank you for your reply,

The way I'm installing Jira as a service is opening a cmd and at (C:\Program Files\Atlassian\JIRA\bin)

-Service install/remove Jira (restart between remove and install).

In the event viewer the error is reported by the "Service Control Manager"

--------------------------------------------------------------------------------

- System

- Provider

[ Name] Service Control Manager
[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
[ EventSourceName] Service Control Manager

- EventID 7024

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8080000000000000

- TimeCreated

[ SystemTime] 2019-10-03T14:05:44.526694800Z

EventRecordID 3989

Correlation

- Execution

[ ProcessID] 612
[ ThreadID] 720

Channel System

Computer DESKTOP-SOIP6UR

Security

- EventData

param1 Atlassian JIRA
param2 %%1
4A0049005200410053006F006600740077006100720065003200340030003500310039003100350030003000320035000000


--------------------------------------------------------------------------------

Binary data:


In Words

0000: 0049004A 00410052 006F0053 00740066
0010: 00610077 00650072 00340032 00350030
0020: 00390031 00350031 00300030 00350032
0030: 0000


In Bytes

0000: 4A 00 49 00 52 00 41 00 J.I.R.A.
0008: 53 00 6F 00 66 00 74 00 S.o.f.t.
0010: 77 00 61 00 72 00 65 00 w.a.r.e.
0018: 32 00 34 00 30 00 35 00 2.4.0.5.
0020: 31 00 39 00 31 00 35 00 1.9.1.5.
0028: 30 00 30 00 32 00 35 00 0.0.2.5.
0030: 00 00 ..

 

---------------------------------------------------------------------------------

 

Thank you

Keep stuck in here

For the latest 8.x version, Edit the Service.bat and replace "set DISPLAYNAME=Atlassian JIRA" with "set DISPLAYNAME=Atlassian JIRA %1". And when running the command to setup the service manually give some custom name instead of just "Jira", so 

service.bat install Jira_8.x

Basically, it is trying to create a service with name "Atlassian JIRA" which might already exist in services from old version. With custom name this clash won't happen

Thank you very much,

for your answer, althoug I've solved the problem., the Instance is in a MV and this happens often when I Update.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

260 views 1 2
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you