Tutorial Doesn't Work - Error: "cannot resolve bundle 'com.atlassian.tutorial.helloworld'

This question is in reference to Atlassian Developer Documentation: Put the Final Polish on the Project in Eclipse

I cannot get the JIRA Helloworld Plugin tutorial to work. (Specifically: https://developer.atlassian.com/docs/getting-started/set-up-the-atlassian-plugin-sdk-and-build-a-project/put-the-final-polish-on-the-project-in-eclipse).

I've run through it a number of times. (I don't even want to tell you how many... ) I've also tried a few other tutorials for Confluence and JIRA and zero luck. I see the same issue with all of them. I'm not sure if there's an issue with how I've setup my dev environment (I'm completely new to JIRA/Confluence development and followed the instructions on how to install the SDK and recommended version of Java, etc.) I have started to see other people posting comments saying that they also cannot get the tutorials to work either, so I'm reaching out for help. For the errors I'm encountering, there is not enough explanation given in the tutorials to understand what is going wrong. If this turns out to be something on my end, I would suggest adding a better explanation of what exactly the plugin creation command generates and how to create these resources without using the auto-generate command.

Here are the details on what's going wrong:

When I run atlas-run to open JIRA and test the plugin, the Helloworld plugin is disabled. I try to enable it manually and get the following error:

ERROR admin .... /rest/plugins/1.0/com.atlassian.tutorial.helloworld-key [c.a.p.osgi.factory.OsgiPluginInstalledHelper] Cannot determine required plugins, cannot resolve bundle 'com.atlassian.tutorial.helloworld'

After that initial error, it keeps trying to load, and then I finally get a timeout error and the plugin does not load:

ERROR admin ... /rest/plugins/1.0/com.atlassian.tutorial.helloworld-key [c.a.plugin.manager.PluginEnabler] Unable to start the following plugins due to timeout while waiting for plugin to enable: com.atlassian.tutorial.helloworld

It looks like the files generated from the atlas-create-jira-plugin-module command do not yield the same files in the completed version of the tutorial hosted at https://bitbucket.org/atlassian_tutorial/helloworld.git

Running atlas-create-jira-plugin-module yields: 
src/main/java/com/atlassian/tutorial/helloworld/api/MyPluginComponent.java
src/main/java/com/atlassian/tutorial/helloworld/impi/MyPluginComponent.java

Meanwhile, the Bitbucket code has:
src/main/java/com/atlassian/tutorial/helloworld/MyPlugin.java

I'm not sure how to resolve this. Any help is much appreciated!

I added a JIRA ticket because I believe there may be a bug: 

https://jira.atlassian.com/browse/JRA-47699

 

 

 

 

 

 

 

5 answers

Hey! After 3 weeks of work on the code I got all JIRA tutorials to work.

  • I used atlas-clean command before each atlas-run command.
  • I used eclipse to edit xml and vm files.
  • For adminUI I used atlas-run --product JIRA --version 6.3

Here are the modified files:

What you will find in archive:

1) pom.xml files: 

  • Some problems with dependencies fixed
  • Versions are fixed

2) atlassian-plugin.xml files:

  • Deprecated methods were fixed

3) MyPluginComponent.java for helloworld tutorial

4) MyPluginServlet.java for adminUI tutorials:

  • Deprecated methods were fixed
  • There were a lot of warnings and i tried to fix it all

5) admin.vm for adminUI tutorials

6) guava-14.0.1.jar that i used as external in the last adminUI tutorial (Store and retrieve plugin data):

  • Its strange but dependency injection for guava doesn't work for me and a lot other programmers (just google it). The only solution that work for me is to download it manually and add it to the adminUI project as external.

Good luck! Have fun!

Oh wow!  Thank you for this!  

These tutorials are so out of date.  I've been having issues with them.  Luckily I saw this post.

Thank you again!

It means that the number of changes to make it work for JIRA 7.x or even 6.4 is big.

Most of tutorials are made for 5.x or 6.2 or 6.1. Of course you can fix all the outdated and deprecated methods and classes with your hands. It took me 2 weeks to go through the beginner tutorials and i think it's not ok.

All of the Atlassian Tutorials are OUT OF DATE.

The same question here.

0 vote

That's actually a bit of a lie - a lot of them are still in date.  What you mean is "Some of them are out of date and it seems to be the ones I've looked at"

0 vote

This topic is little bit old but still there is same issue and big problem with outdated tutorials.

Anyway thanks to people like mr. Roman who doing their best to help.

 

Sometimes I think Atlassian doesn't want outside developing so much.

Totally agree, been bashing away at this for awhile now. Managed an application that works in JIRA 6.3 but now looking to migrate to 7.2+ which requires a whole restructure of code using Atlassian Spring Scanner + annotations.

 

https://bitbucket.org/atlassian/atlassian-spring-scanner/src/1.2.x/README.md?at=1.2.x&fileviewer=file-view-default

 

Can update progress if you so wish, following that link above on how to update code.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

442 views 6 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you