It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trying to install Jira and Confluence on GCP -- HTTP 500 Error

Hi everybody,

 

I am trying to deploy Jira and Confluence on two separate GCP VM instances according to these articles: 

https://cloud.google.com/solutions/deploying-jira-on-gcp

https://cloud.google.com/solutions/deploying-confluence-on-gcp

I have gotten the instances up and running to the point where I can see the setup wizard running on our own domain. However, I get to the step where we need to connect to the database and I get a HTTP Status 500 error after the software tries to setup the database. This happens every time (I have tried this starting from scratch about 3 or 4 times) and it is getting very frustrating. I have also tried doing the 'Trial Setup' where a temporary database is created and it still throws the same error while trying to create the database (which seems odd -- as this should be completely unrelated to trying to connect it to the GCP SQL database). I feel that I have followed the instructions as closely as possible, so if anybody could provide some insight as to how this database connection is causing things to fail please let me know. Thanks!

4 answers

0 votes
Andy Heinzer Atlassian Team Jun 04, 2019

Hi Will,

I see that you are trying to install Jira and Confluence on the Google Cloud Platform (GCP).   While I don't believe this platform is listed in the supported platforms for either Jira or Confluence at this time (which means they technically are not supported), I have to say that I'm not sure if it is possible to do today. 

It might be possible to make this work, but it also might not be possible, and I should preface this respond by stating that Atlassian has not yet tested our server products against this cloud platform to the best of my knowledge today.  I know that other Cloud providers such as AWS and later Azure have has some level of testing and added support for them in prior versions of Jira.

I have to admit that I don't know much about GCP, but from looking at their guide for Jira at least, I'm not seeing any red flags jump out at me in regards to their steps. 

Perhaps we can look more deeply at the source problem here if we could see the logs that Jira creates when it appears to get stuck here.  For Jira I would recommend going into the $JIRAINSTALL/logs/catalina.out log file. This specific log file is created by the Tomcat service when Jira is started up, it tends to have some more detailed bits in regards to the database connections on startup than the atlassian-jira.log file might have during startup / setup.   If we can look at that log it might be able to tell us a clear error or other details about how Jira is starting up that might be helpful here.

Andy

I have the same problem, but Jira is working well, but Confluence after configure the database (or configure the trial database) in the installation the system becomes broken in Google Cloud using the same instructions

Finally if you install the services without using the Google Cloud load balancer the process works fine. I have tried with Jira 8.2 and Confluence 6.15 and now is ok!

That's the trick!

0 votes

I've had the same issues with the Cloud Load Balancer.

I only got through the setup wizard when going directly against the compute engine instance and bypassing the CLB.

After that, you can enable the CLB and connect through that with relative success.

But it does cause me to worry about the inherent stability of the CLB and the appropriateness of using it for Atlassian apps. I get occasional health check failure where the backend can't be picked up. But I usually get the expected page after a refresh.

I'd love to hear if anyone else has attempted this.

So far, we only have a test instance (jira, confluence, bamboo, fisheye, bitbucket), but our IT infrastructure guys really want us to move the whole Atlassian suite to GCP.

Regarding my earlier comment about the CLB ... I found the cause of my CLB performance.

In my various configuration meandering in the GCP console, I ended up with a CLB backend with 2 ports (comma separated): 80, 8080.

But the actual server was only listening to 80.

When the Google Front End (GFE) would try to connect (randomly presumably) to port 8080, it would fail after 4.5 seconds (the default GFE timeout ... not configurable). Then it would re-try (again random port). If it hit 80, all it good... but I've just experienced a 4.5 seconds latency. If it hit 8080 again, it would fail the second attempt (and no more retries) for a total of 9seconds wait before showing a 502 error.

My installation seems much more stable now and we can start some performance testing.

Here are a couple of links that clued me in:

https://superuser.com/questions/1451460/google-cloud-http-load-balancer-slow-performance-or-502-failed-to-connect-to-ba

https://groups.google.com/d/msg/gce-discussion/7ETsl0YH1iQ/TIbUvrJ0AAAJ

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you