I am attempting to migrate from another machine running MySQL 5.6 and CentOS6. I've installed CentOS 7 and MySQL 8, copied the java-connector-8.0.25.jar into /opt/atlassian/8.12.0/lib, imported the mysqldump, and copied over the JIRA home folder and application folders. I've setup the dbconfig.xml according to documentation, yet the application fails to start. I read a few articles online to clear the clusteredjobs table, but that doesn't do anything (since the mysqldump was done from a running instance of JIRA). My plan is to get a working instance and then perform an update to 8.20.
Please pardon my lack of knowledge with JIRA migrations.
Here is the top part of dbconfig.xml:
<?xml version="1.0" encoding="UTF-8"?>
<jira-database-config>
<name>defaultDS</name>
<delegator-name>default</delegator-name>
<database-type>mysql8</database-type>
<jdbc-datasource>
<url>jdbc:mysql://localhost:3306/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=default_storage_engine=InnoDB</url>
<driver-class>com.mysql.jdbc.Driver</driver-class>
Here is the tail of catalina.out pertaining to the error:
2021-12-03 18:09:49,977-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigHandler] Trying to get encrypted password from xml and decrypt it
2021-12-03 18:09:49,978-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigHandler] Database password decryption not performed.
Loading class `com.mysql.jdbc.Driver'. This is deprecated. The new driver class is `com.mysql.cj.jdbc.Driver'. The driver is automatically registered via the SPI and manual loading of the driver class is generally unnecessary.
03-Dec-2021 18:09:50.016 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 5031 ms
2021-12-03 18:09:51,015-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running Jira startup checks.
2021-12-03 18:09:51,015-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Jira pre-database startup checks completed successfully.
2021-12-03 18:09:53,807-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigurationManagerImpl] The database is configured. Now running Database Checklist Launcher
2021-12-03 18:09:53,810-0600 JIRA-Bootstrap INFO [c.a.jira.startup.DatabaseChecklistLauncher] Jira database startup checks completed successfully.
2021-12-03 18:09:53,810-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigurationManagerImpl] The database is configured. Now running Post database-configuration launchers
2021-12-03 18:09:55,147-0600 JIRA-Bootstrap INFO [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from /var/atlassian/application-data/jira/dbconfig.xml
2021-12-03 18:09:55,150-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigHandler] Trying to get encrypted password from xml and decrypt it
2021-12-03 18:09:55,150-0600 JIRA-Bootstrap INFO [c.a.j.config.database.DatabaseConfigHandler] Database password decryption not performed.
2021-12-03 18:09:57,831-0600 JIRA-Bootstrap INFO [c.a.jira.upgrade.PluginUpgradeListener] [plugin-upgrade-listener] Created
2021-12-03 18:09:57,956-0600 JIRA-Bootstrap INFO [c.a.jira.startup.DatabaseLauncher] Database transactions enabled: true
2021-12-03 18:09:57,956-0600 JIRA-Bootstrap INFO [c.a.jira.startup.DatabaseLauncher] Using JIRA's default for database transaction isolation level: 2
2021-12-03 18:09:57,960-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]
Database configuration OK
___ Database Configuration _________________
Loading entityengine.xml from : file:/opt/atlassian/8.12.0/atlassian-jira/WEB-INF/classes/entityengine.xml
Entity model field type name : mysql8
Entity model schema name :
Database Version : MySQL - 8.0.27
Database Driver : MySQL Connector/J - mysql-connector-java-8.0.25 (Revision: 08be9e9b4cba6aa115f9b27b215887af40b159e0)
Database URL : jdbc:mysql://localhost:3306/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=default_storage_engine=InnoDB
Database JDBC config : mysql8 jdbc:mysql://localhost:3306/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=default_storage_engine=InnoDB
2021-12-03 18:09:58,025-0600 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]
___ Starting the JIRA Plugin System _________________
03-Dec-2021 18:10:08.092 INFO [http-nio-8081-exec-4] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header
Note: further occurrences of HTTP request parsing errors will be logged at DEBUG level.
java.lang.IllegalArgumentException: Invalid character found in method name [0x160x030x010x020x000x010x000x010xfc0x030x030x970xbb0xb5O50x88,0x1d0xe60xfc0x0aiO70x110xf7J\V0x09~0xb6'0x1a@0xf40x160xe50xb90xe6SJ]. HTTP method names must be tokens
at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:432)
at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:502)
at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:65)
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:818)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1627)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:748)
log4j:WARN No appenders could be found for logger (com.atlassian.analytics.client.properties.LoggingProperties).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
2021-12-03 18:10:35,882-0600 ThreadPoolAsyncTaskExecutor::Thread 39 INFO [c.a.ratelimiting.internal.RateLimitingConfiguration] Rate Limited Request Handler ENABLED
Security framework of XStream not initialized, XStream is probably vulnerable.
2021-12-03 18:15:24,522-0600 JIRA-Bootstrap ERROR [c.a.r.d.internal.dao.QDSLSystemRateLimitingSettingsDao] Caught error initializing system rate limiting settings: [SystemRateLimitingSettings(mode=OFF, bucketSettings=TokenBucketSettings(capacity=50, fillRate=10, intervalFrequency=1, intervalTimeUnit=Seconds), jobControlSettings=SystemJobControlSettings(reportingDbArchivingJobFrequencyDuration=PT1M10S, reportingDbRetentionPeriodDuration=PT24H, bucketCollectionJobFrequencyDuration=PT5M, bucketCleanupJobFrequencyDuration=PT15M, settingsReloadJobFrequencyDuration=PT1M))] in DB - rolling back transaction
2021-12-03 18:15:28,665-0600 JIRA-Bootstrap ERROR [c.a.jira.upgrade.PluginSystemLauncher] A fatal error occured during initialisation. JIRA has been locked.
com.atlassian.jira.InfrastructureException: Error occurred while starting component 'com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor'.
at com.atlassian.jira.component.pico.ComponentManager.startStartableComponents(ComponentManager.java:339)
at com.atlassian.jira.component.pico.ComponentManager.earlyStartPluginSystem(ComponentManager.java:252)
at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:45)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:145)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:301)
at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:196)
at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:137)
at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:104)
at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)
at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:102)
at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:154)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.RuntimeException: com.atlassian.scheduler.SchedulerServiceException: Unable to either create or replace clustered job: ImmutableClusteredJob[jobId=com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor,jobRunnerKey=com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor,schedule=Schedule[type=INTERVAL,intervalScheduleInfo=IntervalScheduleInfo[firstRunTime=Fri Dec 03 19:15:28 CST 2021,intervalInMillis=3600000]],nextRunTime=Fri Dec 03 19:15:28 CST 2021,version=1,rawParameters=(null)]
at com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor.scheduleCleanup(DefaultTemporaryWebAttachmentsMonitor.java:75)
at com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor.start(DefaultTemporaryWebAttachmentsMonitor.java:61)
at com.atlassian.jira.component.pico.ComponentManager.startStartableComponents(ComponentManager.java:335)
... 11 more
Caused by: com.atlassian.scheduler.SchedulerServiceException: Unable to either create or replace clustered job: ImmutableClusteredJob[jobId=com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor,jobRunnerKey=com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor,schedule=Schedule[type=INTERVAL,intervalScheduleInfo=IntervalScheduleInfo[firstRunTime=Fri Dec 03 19:15:28 CST 2021,intervalInMillis=3600000]],nextRunTime=Fri Dec 03 19:15:28 CST 2021,version=1,rawParameters=(null)]
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.scheduleClusteredJob(CaesiumSchedulerService.java:188)
at com.atlassian.scheduler.caesium.impl.CaesiumSchedulerService.scheduleJob(CaesiumSchedulerService.java:136)
at com.atlassian.scheduler.core.DelegatingSchedulerService.scheduleJob(DelegatingSchedulerService.java:62)
at com.atlassian.jira.web.action.issue.DefaultTemporaryWebAttachmentsMonitor.scheduleCleanup(DefaultTemporaryWebAttachmentsMonitor.java:73)
... 13 more
2021-12-03 18:15:30,413-0600 JIRA-Bootstrap ERROR [c.a.jira.startup.DefaultJiraLauncher] JIRA has failed to start because of the following errors: [(Event: Level = (EventLevel: fatal) , Key = (EventType: startup-unexpected) , Desc = We couldn't start JIRA , Exception = An error occurred while trying to start JIRA. We can't give you any more detail right now, we suggest checking the logs for more detail and contacting our support team.<br/>See our documentation for more information on contacting our support team and creating a support zip.)]
2021-12-03 18:15:30,416-0600 JIRA-Bootstrap INFO [c.a.jira.startup.LauncherContextListener] Memory Usage:
---------------------------------------------------------------------------------
Heap memory : Used: 924 MiB. Committed: 1978 MiB. Max: 1981 MiB
Non-heap memory : Used: 297 MiB. Committed: 322 MiB. Max: 1536 MiB
---------------------------------------------------------------------------------
TOTAL : Used: 1221 MiB. Committed: 2299 MiB. Max: 3517 MiB
---------------------------------------------------------------------------------