Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The filter <filter name> could not be saved.

A few months ago I created a filter which is basicly a filter to group multiple projects in 1 board.

project in (IC, DWV, LOC, DSN, LV, BR, INP, MAP) ORDER BY Rank ASC

All the projects where created with my account so I am (I assume) owner of all these projects.

The filter works as desired.

 

Now, I want to edit this filter but when I make a change (big or small) it says that "The filter could not be saved". 

That's it. No more info. I have no clue.

I made my user administrator on all projects, just to be sure.

 

Anyone has an idea?

3 answers

Hey all,

 

I have experienced the same issue a couple of times and here is my workaround:

* Remove the permissions from your filter

* Edit your JQL query

* Save the changes

* Give the previous permissions again

 

I hate to see this error again and again but at least this workaround works every time.

I have a user getting this error, and when I simulate her login, I am getting the same error, but what I ended up doing was I created a new filter query using "Save As" and then having the board that was using the filter look at that new filter query instead of trying to save the current one.

  1. Change your JQL in the filter query
  2. Click "Save As" and give the updated filter a new name like "<filter name> v2.0"
  3. Pull up the board using old filter and in top right click the ellipses and go to "Board settings"
  4. Under "General" locate "Saved Filter" and click the pencil icon.
    filter query1.png
  5. Type the name of the new filter and select it when it appears. It will save automatically.
  6. Go back to the board and refresh.

 

I still don't know why it wouldn't allow my user to edit her original query and save it, but this is the workaround since a filter needs a board.

UPDATE: Well I tried the above and at first I THOUGHT it worked but then the owner came back to me a bit later and said she couldn't see the board! So I had to change it back to the original query.

I sent in a ticket to Atlassian support and they located the problem, A user group that was shared out by the ORIGINAL owner of the board, the new owner was not a member of. As a result, since she was not a member of that user group (administrators-confluence) she was not able to save the new query.filter shares.png

I simulated her login (as sysadmin) and removed the Group share and saved then re-did the filter query, and it now allows me to save.

Has to do with permissions. The permission system in Jira is way to complex and messy. Made myself site admin so I can do "everything" because it is impossible to find which right affects what in Jira.

 

Very messy and hard to maintain.

Deleted user Mar 03, 2020

I want to say that you would need a Global Permission for "Share dashboards and filters" in order to accomplish this (site admin has this permission by default).

Thanks, not sure if this was the cause because we tried a lot of rights.

 

Also, in the past I was able to change the filter with my old permission set. Suddenly this stopped working. 

Like Deleted user likes this

Hi, I'm experiencing the same problem at the moment, is there any hint how to solve this? because the permission is still the same though

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you