The field was added successfully, but you do not have edit permissions.

The field was added successfully, but you do not have edit permissions.

what does this mean? (I'm the site admin)

7 answers

Hi Daniel,

I think you have added field through Admin helper right ?

Check if you have Edit Issue permission on that Project through Permission scheme.

Taha

I believe this error can also indicate that the field is missing from the issue edit screen.

I'm getting the same message, being an administrator with all permissions. It happens when I add a field with "multiple versions" type, but not with others.

I got the same message, but the field did not show. It seems the message is wrong or misleading, as it had nothing to do with edit permissions.

The field was simply empty for the issue, so it didn't show, although it was on the right screen.

Unfortunately, in JIRA 7.3+ the "Where's my field?" seems to be missing, so there is no way to really find out why a field is not showing.

Were you ever able to figure this out? 

Gaston Valente Community Champion Jul 27, 2017

Adam,

Maybe you're an administrator but you don't have the edit permission on that particular issue.

As an administrator you can add yourself to a group or role that has this permission.

I did have edit on everything. Turns out it was a Behavior script I was unaware of.

I'm having this same problem. I'm the administrator and have edit permissions but have been wrestling with this add-on for a few hours now with no success. How did you resolve the behavior script, Adam?

Was this issue ever resolved? It's just happened to me as well.

I have exactly the same problem.

I think its not a permission-related issue because I'm using the default-project-config when I started my plugin by using "atlas-run". I also double-checked that I have Admin-permission on the project.

April 2018 and this issue hasn't been solved?

I am having the same issue, did anyone find a solution for this ?

Yes, they amended user so that they have the right permissions

but it is not working even after giving the right permissions.

Then you have not given the right permissions.We can't really tell you a lot more than that unless you give us the detail of what you are setting up and what you see when you try things.  The error message in the original question is solved by giving people the right permissions.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,946 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you