The {code} block does not work for our newly JIRA OnDemand 6.4-OD-14-082

Hey all.

Maybe someone knows more about this.

We recently got JIRA onDemand, and we have version 6.4-OD-14-082.

 

However, in issues everytime we use the {code} block, it doesn't get rendered as code at all. You see {code} in plain text viewing at the comment.

code_block.png

Are there any settings that controls this, or any other advice that would help us understand why it isnt getting parsed/rendered correctly?

Thanks.

 

*Update feb 16*

I tried Ben's suggestion with using {code:} which didn't work either:

 Image37.png

3 answers

1 accepted

We submitted a ticket to support and asked for help.

Apparently, two modules / system-addons were disabled for us, which we didn't see. They enabled it and everything now works as expected.

The modules they enabled were:

  • Enabled add-on module noformat (com.atlassian.jira.plugin.system.renderers.wiki.macros:noformat)
  • Enabled add-on module code (com.atlassian.jira.plugin.system.renderers.wiki.macros:code)

Thanks. This was our issue too. The disabled modules can be seen under the "Wiki Renderer Macros Plugin" system add-on.

Possibly caused by having a Syntax Highlighter add-on installed in our Server instance when we migrated to Cloud.

I was not able to enable the modules myself and had Support do it.

Hi Christoffer,

Maybe it has something to do with the Wiki Style Renderer being disabled for the comment field.

You can refer to the following documentation when configuring Renderers:

However, please raise a support ticket if the problem cannot be solved, so Atlassian Support can take a look at your instance logs.

 

Thanks!

0 vote
Peter Bengov Community Champion Feb 13, 2015

Hey Christoffer,

Try using 

{code:}
	your code
{code}

That is - add the ':' in your opening bracket.

 

Hey. I have tried this, without any luck :S

I have updated my main issue with more details.

Peter Bengov Community Champion Feb 16, 2015

It's look like you have some kind of a text editor installed as a plugin. It that so? Try disabling it and try again. Maybe this will help. Peter

Its the rich text editor. I advice from Andre (first comment) and disabled rich text editor renderer, tried it, enabled it again, tried it - without luck. But I will most try disabling various stuff again. Thanks.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

680 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you