It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The {code} block does not work for our newly JIRA OnDemand 6.4-OD-14-082

Hey all.

Maybe someone knows more about this.

We recently got JIRA onDemand, and we have version 6.4-OD-14-082.

 

However, in issues everytime we use the {code} block, it doesn't get rendered as code at all. You see {code} in plain text viewing at the comment.

code_block.png

Are there any settings that controls this, or any other advice that would help us understand why it isnt getting parsed/rendered correctly?

Thanks.

 

*Update feb 16*

I tried Ben's suggestion with using {code:} which didn't work either:

 Image37.png

3 answers

1 accepted

4 votes
Answer accepted

We submitted a ticket to support and asked for help.

Apparently, two modules / system-addons were disabled for us, which we didn't see. They enabled it and everything now works as expected.

The modules they enabled were:

  • Enabled add-on module noformat (com.atlassian.jira.plugin.system.renderers.wiki.macros:noformat)
  • Enabled add-on module code (com.atlassian.jira.plugin.system.renderers.wiki.macros:code)

Thanks. This was our issue too. The disabled modules can be seen under the "Wiki Renderer Macros Plugin" system add-on.

Possibly caused by having a Syntax Highlighter add-on installed in our Server instance when we migrated to Cloud.

I was not able to enable the modules myself and had Support do it.

Hi Christoffer,

Maybe it has something to do with the Wiki Style Renderer being disabled for the comment field.

You can refer to the following documentation when configuring Renderers:

However, please raise a support ticket if the problem cannot be solved, so Atlassian Support can take a look at your instance logs.

 

Thanks!

0 votes

Hey Christoffer,

Try using 

{code:}
	your code
{code}

That is - add the ':' in your opening bracket.

 

Hey. I have tried this, without any luck :S

Like Shawn Becker likes this

I have updated my main issue with more details.

It's look like you have some kind of a text editor installed as a plugin. It that so? Try disabling it and try again. Maybe this will help. Peter

Its the rich text editor. I advice from Andre (first comment) and disabled rich text editor renderer, tried it, enabled it again, tried it - without luck. But I will most try disabling various stuff again. Thanks.

@Peter B _Taboola_ 

This worked for me! Thank you very much.

 

{code:}
 your code
{code}

Thank you 

{code:}

I am trying code block

{code}

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you