Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Swimlanes by Epic don't work in a Kanban dashboard



I have created a Kanban board and I want swimlanes = Epics

However, the board does not display any swim lane.

When running the same filter on an issue search view, it does return some Epic links but not the Epic names.

With other boards, I don't face this issue and I am able to see swim lanes by Epic

Any suggestion how to fix this?


- screen copies of the board set-up parameters and result (i.e. no swim lane)

- screen copy of the issue search view (using the same filter as the board)

- example of another board with swim lanes by Epic (works as expected)2019-06-26_18-10-38.png2019-06-26_18-06-02.png2019-06-26_18-04-22.png2019-06-26_17-37-29.png2019-06-26_17-51-37.png

4 answers

1 accepted

2 votes
Answer accepted

Solved. The filter that I used was excluding Epics

Hi Charles, I have the same problem. My filter contains epics but the option "swimlane by epic" is NOT working.

By the way, I'm using a team managed project, with epics, stories, and subtasks.

What did you do to solve it?


Like wouter de wit likes this

My filter makes no mention of epics and several of these tickets have epics, but when I set the swimlanes to epics, it only produces one lane with all the tickets that don't have an epic?

Same issue here. I noticed it only happening when the filter includes specific assignees. The moment I remove that from the filter, all Epic swimlanes show up.

Hmmm.  I must test that!

I've also the same issues.
Tickets with epics assigned are not visible when creating a Kanban board based on a valid filter with Swimlanes as Epics.

It feels indeed like a bug

Like # people like this

vote +1 
if no swimlanes selected - all issue
if epic swimlanes selected - single lane with issues with no epic assigned 

Like # people like this

It's not a bug, It's because some filters accidentally filter out Epics.
For example most companies don't assign people or sprints to epics so if you filter by one of those - you unintentionally filter out all epics. The easy solution is adding Type = Epic to your JQL.

For example:

  • project = myproject AND sprint = mysprint
    Does not show swimlanes because it filters our my epics.

  • project = ED AND (sprint = mysprint OR type = Epic)
    Works perfectly!

Nope. My filter includes epics. Still no swimlane. 



What would one do if their query doesn't exclude "type=Epic" yet some epics are missing?

Suggest an answer

Log in or Sign up to answer