Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Subtasks are not showing as an issue type

Edited

I have tried and tried and tried with this but am just at a complete loss. I have looked through all the boards and all previous questions to no avail. I am new to Jira and am simply trying to create a subtask under an existing task and the option is not there.

Subtasks are enabled. Under Settings > Issues > Sub-Tasks, it says "Sub-Tasks are currently turned ON.". 

When I open a task and click the "more" (...) button on a Task all I see is an option to "Add Apps". There is no "Create Subtask" button.

When I click "Create", under the "Issue type" drop down I get Task, Epic, Story and Bug. Sub-Task is not there.

I know this question may have been asked before but I have been trying to do this for about three hours now and I cannot make it work.

2 answers

1 vote

Welcome to the Community!

To create a sub-task, you have to have added one or more sub-task types to your project(s).

In a team-managed project, go to Project Admin -> Issue types and look at the list of types available,  At the bottom, there is a "sub-task" type you can add.

In a company-managed project, go to Project admin and find the "issue type scheme" - edit that, and you'll see you get the option to "add new issue type", which will ask you for a name and whether it is going to be a standard issue-type or a sub-task.

Once you have added the sub-task type to your project, you will see "create sub-task" appear in the menus for all your issue level issues in your project.

Thanks for your reply. I have followed the steps above but I'm still not seeing it. 

Selected settings > issues and added 2 new issue types as sub-tasks. Screenshot 2021-12-25 at 12.02.20.png

Created a new task and added it to my current sprint. Still no subtask option. The only option is "Add a child issue".

Screenshot 2021-12-25 at 12.02.45.png

Ok, two more things to check.

Your first screenshot is the list of issue types.  It tells us that you definitely have two in your system, but have you associated them with the project as well?  What does the "issue type scheme" for the NTP project say?  Does it include either of the sub-task types from the global list?

Second, what type of issue is NTP-10?

Hi Nic

Yes, I have definitely associated it with the project. Issue type schemes are as follows, you can also see where it has the 2 sub-types associated with the project. 

If you would like access to the project to look at it yourself I'd be happy to grant it you, it's only a free subscription to help me learn Jira, but I'm pretty close to just giving up if something so basic is going to be this obscure to fix. It doesn't bode well for Jira as a whole. 

Screenshot 2021-12-25 at 18.56.09.png

Secondly, NTP-10 is a task: 

Screenshot 2021-12-25 at 18.57.06.png

Ah, those two screenshots are really useful.  The first one shows us the issue types that are in the default issue type scheme, but paired with the second, there's a dead giveaway.

The icon for NTP-10 is a white tick on a blue background.  The default issue type scheme with the sub-tasks in it does not have tasks in it.  

So, the NTP project is using an issue type scheme that is not the default!

My guess here is now that the issue type scheme for NTP does not have sub-tasks.  You can either edit the NTP scheme to add the sub-task type(s), or swap NTP out to use the default scheme.

Hi Nic

Hmm. I'm a bit confused by that one too. When I look at the Settings > Issues > Issue Type Schemes, it seems to say I have added these 2 sub tasks types to the right scheme (Default Issue Type Scheme). Screen shot below. 

Screenshot 2021-12-25 at 20.40.27.png

This seems a bit over complicated. All I want to do is add a sub task to a task - something which is advertised as standard functionality, but for me it's proving to be nigh on impossible!

It's not.  That issue type scheme is not in use in the NTP project.

The NTP-10 issue is of a type called "Task" and has the little white/blue tick icon.

That scheme does not include "Task", so it is not used by NTP.  You can't have an issue of a type that is not in use in the project.

NTP is not using that issue type scheme.

OK - that's starting to make sense but where do I check what issue type scheme NTP is using and / or change it? 

I have selected the project, then Project Settings > Issue Types and I see the following. This would seem to imply that tasks are available to the project. 

Screenshot 2021-12-25 at 21.01.38.png

Am I looking in the wrong place? 

Also - I'm pretty sure I do have tasks in this project. Again, screen shot below from one of my sprints showing that. Forgive me if I am misunderstanding something. 

Screenshot 2021-12-25 at 21.22.09.png

Ahh, no, I see.

You are looking at a team-managed project.  These do not use issue type schemes, they are configured individually.

Your first screenshot there shows that you've already added subtasks to the project, so all you need to do is go to an issue you want to break up into sub-tasks and click "add a child issue"

Note that team-managed projects only support a single sub-task type, called "sub-task", you can't do your "fix needed" and "requirement update" (yet)

0 votes
Fabian Lim Community Leader Dec 24, 2021

Hi @Nick Gower-Jones

Welcome to the community.

The "Blue" Create button is only used to create main tasks and not subtasks and that's why it doesn't show as an option.  Subtasks can only be created from a main task.

In cloud here is a screensoht:

subtask.png

I hope this helps.

Hi Fabian

Thanks for your answer, but this is exactly my problem. When I open up an issue, there is no "create subtask" button showing, as you can see from this screenshot. Screenshot 2021-12-25 at 10.25.27.png

You can see from this screenshot that I have added the subtask issue type: 

 

Screenshot 2021-12-25 at 10.25.52.png

 

...and I have subtasks enabled. What am I doing wrong?

 

Screenshot 2021-12-25 at 10.28.35.png

Fabian Lim Community Leader Dec 25, 2021

Have you tried clicking on "add child issue" and see what happens?

It seems to add something that look like a subtask (the icon is the same), but I can't select either of the new subtask types which I have added to the issue type scheme. I have added two child issues in the screenshot below to illustrate

Screenshot 2021-12-25 at 19.04.37.png

Every bit of documentation I see seems to tell me I can create sub tasks but I can't see how it's done. I'm doing this exercise to learn how to use Jira, but if something as simple as this is going to be this painful I'm kind of at the point of giving up now. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you