Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Story Points not showing up on Scrum Board


We changed from a kanban board to scrum board, and added story points to all issues. We've added story points to each issue (see image linked below), but the estimates are not showing up on the board NOR on the backlog view. What am I missing? 


9 answers

1 accepted

4 votes
Answer accepted

For anyone experiencing anything like this... This was the response fro Atlassian, and it solved the problem. 


Just found the root cause of the problem.

The Story Point custom field was without a search template.

This configuration you can see be accessing:

  1. custom fields
  2. find the Story Point custom field
  3. click More button (...) > Edit



The option next to search template was set to None. I changed it to Number searcher and it fixed the problem.

Ah, great, thank you for chasing this up, and thank you ten times more for posting the cause!

I should have had the imagination to remember that a field with no searcher won't report correctly.  I think I had forgotten because it is very very rare that an admin will remove a searcher from a field, especially an important one like story points.

Where can I access the initial custom fields option? If I go to Issue > Edit > Custom > Where's my field? 
 I can't see the 'More' option. I'm also not using Next Gen 

Like chris girolamo likes this

In my case, I had the search template set to Number Searcher, but my Context was still set to 'Story' issues only. I expanded Story Points applicable issue types to 'Any issue type' and that seems to have gotten my story points propagating to the places I need (Backlog, sprint summaries, and Burndown Charts.

Like Regina Kondracki likes this

For me none of this is working. The story points field is set to "Global All Screens" and it doesn't show anyway. I tried the "Wher's my field?" and all I get when I pick it is a greyed out screen (modal disappears, but the overlay remains). 

I think I am about done with JIRA. I don't know who their IA and UX people are but they suck balls. I live in fear of having to change something (security.. total FML moments) because it's simply not intuitive at all. 

Bye bye JIRA. 

Like # people like this

I think Atlassian doesn't even use their own product. 

Like # people like this

This solution did not work for me as seen below:

Screen Shot 2019-11-04 at 8.48.49 AM.pngScreen Shot 2019-11-04 at 8.48.23 AM.png

I have the same issue as rsurya. Field doesn't show up on Kanban board.

Like # people like this


I filed a ticket to Atlassian and they helped me out. Seems to work for me, here's what they said:

In the end, there was an issue with the field context of the "story points" custom field and the fix for this was to delete and create it again.


  • Go to the Custom fields screen
  • Click on the "Configure" option
  • Delete the Default configuration context and re-add it again



Like Kiley likes this

Thanks....after 4 hours of working on this, this solution worked.  Something so freaking simple. The Jira folks should be embarrassed

Like Kiley likes this

Yeah, I had the same issue as @chris girolamo and @rsurya .

The only thing that solved it was what @rsurya posted. Atlassian feels like the new SharePoint lol

Like # people like this

I had the same issue - Board not showing Story Points in the grey bubble. Showing Estimated Hours (which we were originally tracking against). Whilst, I was able to add Story Points to the bottom of each card as one of the 3 extra fields (via Board config > Card Layout) but that just showed as a number, no label. 

To stop the grey bubble showing Time and show Story Points, I had to change the Board Config > Estimation > Time Tracking value from 'Remaining Estimate and Time Spent' to 'None' (note: Estimation Statistic was already set to 'Story Points').

Once I did that, grey bubble on board shows Story Points value.

That worked for me.  Thank you!

worked for me too! Thanks.

Thanks!  This worked for me.

@Ben Nowacky

Check you board filter query has the missing story point project name in it.

In the case where you're not seeing the points on the board, but there's an empty grey box where it should be, AND you know you have set story points, for some reason there are TWO story points fields. "Story Point Estimate" is for next-gen projects. "Story Points" is for classic. I suspect you've set your story points in one of the fields, and the board is showing the other field. 

One alternative solution might be this (solved it for me):


  1. Go to Settings
  2. Select Fields --> Custom Fields
  3. Search for the field you need to show
  4. Select "Edit Configurations"
  5. Select the issue type or project where it should apply

Anyone else experiencing this problem who doesn't have sufficient access rights to edit their fields might want to try this.

My board was configured with Estimation linked to Story Points. Editing the estimation in the preview screen (the little one on the left of the screen when you click on an issue) would populate the grey bubble on the story but not the Story Points field in the issue. Adding the story points to the field in the issue only did not populate either the grey bubble or the estimated value in the issue preview which was still showing as "unestimated".

I fixed this by changing the field in the board configuration, scrolling down the list of fields until I found the field Story points (note the lack of the capital P) and selecting this. This may be peculiar to our organisation's set-up but you have to select the right one or you won't get them to connect. 

I've experienced similar issues when creating dashboards where there are multiple fields for status, start date, end date etc.

So after running through everything previously posted here, I found that if you go to your project settings  > Fields > In the top right click the "(gear) Actions" dropdown and select Edit Fields > scroll down to Story Points and click "Required" on the right for Story Points > Go back to your Projects backlog and try and create a new issue, it will bring up the full edit for an issue and yell at you for not having a story point value. Go ahead and enter a value and then create the issue. You will now note that it shows the story point value both on the issue in the backlog and in the info panel on the right for the issue (click on the issue to see this). Now you can go back and change Story points from Required to Optional and all future issues will have story points as an editable field on the right-hand info panel.

Note that this is not to show the story point values when switching over to Scrum, but rather how to get story points as a field on Scrum boards. Definitely something Atlassian needs to look into.

Bumping this for help. Still can't get story points to show up, and hoping someone can help me out ?! 

Pick one of your stories, and go into it (the main issue view).  Click edit, then look to the top right for "configure fields".  Use the "where's my field" option to uncover where it's not been set up.

Thanks @Nic Brough _Adaptavist_, but the ‘story points’ field is showing up , you can see it in the top screenshot. The stories however remain ‘unestimated’, so the points aren’t showing up on the left in the grey bubble nor on the scrum board in the grey bubble. 

That's why I was asking about the field.  You need to put something into it, which means editing the issue.  My guess was that you have no data for them, as the grey circles contain nothing.

@Nic Brough _Adaptavist_, We do have data for the field. We've entered story points. The screenshot you see from the first post has story points entered in. 

So that grey dot on the list on the left is not mapped to 'story points, which I believe is the issue, but I'm not clear how to map that to that field.

I'm sure I'm missing something simple, but can't figure out how to get those story points to show up, and how to get total velocity to show up at the top.

Could the "estimation statistic" be looking at the wrong field?

that's what I'm thinking as well, but I don't know how to map the estimation statistics to the story points field.

It should be in the second picture you posted - the estimation field for the board (not the time tracking bit, just estimation).  It would not be the first time I've run into Jira systems with more than one "story points" field, and the wrong one is selected!

Thanks @Nic Brough _Adaptavist_. Just checked, but don’t see another story points field. 

There is no ‘estimation’ field at all in custom field or anywhere. Only story points and time estimates.

Sorry, I should have said "estimation statistic" as the full name of the field in your screenshot.

There is no estimation statistics field anywhere in custom fields or anywhere else. 

It's in your second screenshot

 That second screenshot is what we changed in order to change how stories are estimated. 


That field only has one story points selection in there: 

Ok, good.  If that says story points are selected, then the issues in the backlog do not have story points set.

Could you select one that is on the backlog with a grey circle and look at it in the full issue view?

Like Khaled Sallam likes this

They do have story points. The first screenshot is the story selected. If you look on the right you can see the story points field with a 3 point estimate. 


The whole backlog is not estimated but the current sprint is and none of those are showing in the list view. 

Mmm.  Can you have a look at three more things?  All long-shots, but need to be checked.

  • What status is the issue in?  And what is the status category of this status?
  • Could you re-index the project and see if that changes anything.
  • Could you check that the Story Points field there is a simple numeric field type?

@Nic Brough _Adaptavist_

- Issues are in all status and categories, so it seems to be independent of that, everything from backlog to done. 

- Apparently re-indexing is deprecated and not supported any longer! 

- The Story points field is indeed a number field: 

Ok, that rules out a couple more things (actually quite a lot).  But I could still use a look at a single issue's status and status category.

@Nic Brough _Adaptavist_, couple screenshots here:

Here is the scrum Board. You can see no estimates here either: 

here is a single issue status. You can see the story points in the right column.  This is in the "TO DO" column now.: 

Here is the same issue with the 'status' column expanded so you can see the other status options: 

Ok, that's got to be a bug, we've ruled out status, the possibility of the wrong type of field, multiple Story Point fields, and that the field is used for the estimation on the board

This needs raising with

Thanks Nic ! I've opened a support ticket. I've managed a few jira installs at different companies, and thought I was going crazy here when this wasn't working. Thanks for the validation that either we're both crazy, or this is not working :)

Hello Ben,

Were you able to get response from Atlassian.

In my projects, one of the projects is not displaying story points and

rest of the projects are displayed.



0 votes
Tuncay Senturk Community Leader May 07, 2018

Hello Ben,

Go to board configuration and click on Estimation tab.

Make sure that "Story Points" is selected under Estimation Sttistics

Thanks, but already did that. The results in the screenshot is with estimations = story points already applied. 

Like # people like this

worked! thanks

This solution also did not work for me, as seen below:


Screen Shot 2019-11-04 at 8.48.49 AM.pngScreen Shot 2019-11-04 at 8.51.16 AM.png

nash I'm New Here Sep 20, 2022

None of the above solutions have worked for me and I'm using JIRA Cloud. @Nic Brough _Adaptavist_

Suggest an answer

Log in or Sign up to answer