Story Points missing in Sprint Report, but stories were estimated prior to starting the sprint

We have just started a a sprint. All Stories were sized with story points assigned prior to the start of the sprint.

However I have noticed in the sprint report that only 7 out of the 15 stories in the sprint have story points next to them, the remainder have a '-'. As mentioned, all stories had story points befor the sprint was started.

Any help would be appreciated as this is going to impact on our velocity reporting.

11 answers

Hi - we are experiencing the same problem. Noticed it back in December '13 and now again in April '14.

We are using version 6.0.8 - is there an update with a fix released?

We are also experiencing this issue. Any ideas on how to work around it until it is resolved?

0 vote
Timothy Chin Community Champion Aug 29, 2013

You will need to confirm each an every issue that you think the Story Points are missing by going into the issue history and checking if its gone. Else, you can just add the points back but you'll get a weird report.

thanks for the reply. Every Story Still has story points assigned to them.

And Another weird thing I am seeing in the Sprint report is 3 additional stories that are NOT in the sprint. These 3 stories were in the sprint but I moved them out to the backlog before the sprint was started. They do not show in the sprint on the plan or work view,only in the sprint report.

I have the same issue here, I think the last update went wrong. My Sprint Burndown report is useless now. He doesn't take only the select sprint data, but all the other sprint. If I dont have any sprint plan in the future it works

We raised this as an issue and it is being looked into. From my investigation it seems the problem is related to sprints that were created, but not started at the time we ran the last update.

I had another sprint created but not started, which I removed all issues out of and tried to delete and I got some message saying it could not be deleted due to its workflow status. On a test server I tried starting this sprint with only one item in it and in the sprint report, it contains lots of other stories not in the sprint, but which were in the sprint at the time of the last jira update. I also created a brand new sprint with items that had no stories points in for the other sprint, and they show up correctly in the sprint report, which further indicates that it is a problem with the sprints rather than this stories.

We had the exact same problem.

I have the same issue as everyone here. Has Jira provided a fix for this. I really need to be able to present the correct reports to leadership who have finally accepted the use of Scrum and Jira but will now have issues if this doesn't get fixed.

Could you please provide a version number since I'm trying to avoid this problem. I'm about to update both JIRA and JIRA agile...

Cheers Christian

version 6.0.5

I have the same issue here.

I started print on 8/27 with story points and completed the sprint on 9/10.

The story points are missing the sprint report shown as "-".

I created other sprints a few weeks ago and started one new sprint on 9/10, will these sprints have the same issue or not?

If yes, how can i avoid this from happening again?

The sprint we have created after the upgrade is not affected at least on our test system. I will be starting our next sprint later today and will update here if any issues. As far as I know it only relates to Sprints created but not started after the upgrade. For these remove your issues out onto the backlog. Then try to delete these sprints. If you cannot as due to their workflow status,then you will have to copy your board and delete the original. These problematic sprints wil not showup in your new copy of the backlog. Then in the new copy, create your sprints again, and copy your issues into them. This should then be Ok.

We just completed our sprint where we first saw the issue. However the non-completed stories went back into one of the screwed up sprints I had previously created, which somehow magically reappeared. I moved the stories out onto the backlog, and tried to delete the problem sprint. I go the same workflow error message but when I refreshed it had gone. Im sure it is in the system somewhere and may reappear at some point (until we get a fix) but for now things are Ok.

The sprint report for our new sprint is screwed up to. So I dont think it just related to sprint that were created, but not started before the last Jira upgrade.

Also I just did the following test on our test system

1) Created a brand new Sprint

2) Added 4 Stories to the sprint and created sub-tasks for the first three, each of which was estimated.

3) Pulled the 4th Story out of the sprint onto the backlog.

4) Started the Sprint

Guess how many stories show up in the Sprint Report?

5!!!!!! What the hell.

The 3 stories that are in the sprint are included, as is the 4th one which I pulled out and back onto the backlog - I was suspecting this would be the case as I thought that any story in the sprint at any point was being included. Plain Wrong and a common enough thing to do eg negotiate with the team which stories should be in the sprint during sprint planning.

But the 5th one, has stumped me. I have absolutely no idea where this came from.

Jira People - Are you taking Note?

I also have the same issue in my sprint report not refecting the revised story point after sprint started. What is the solution to rectify the sprint report?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

232 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you