It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sorting by assignee or by reporter returns error

I have an issue with using Jira. When I trying to sort tickets by reporter or by assignee I have ability to choose only my profile. And when I start enter searched username I get a message:

"The Jira server was contacted but has returned an error response. We are unsure of the result of this operation." right after first letter was entered.

Screenshot_4.png

Where I need to report this issue? Or porbably someone can help me with this?

1 answer

0 votes

Hello Yevhenii, 

Welcome to Atlassian Community!

When we can't search for other users on a site, it's usually related to the Browse users and groups permission.

Can you please let us know if you can find users when searching on fields like Assignee?

If you use the advanced search, does it return the results? For example, assignee = "user@domain.com"?

If you can't find, you need to check with the administrator if the group you are part of is added to the permission I mentioned previously.

They can find this option on Jira settings > System > Global permissions.

Regards,
Angélica

Hello Angélica, 

I've tried to use advanced searching with the user's mailbox by assignee and by reporter. (assignee = username\u0040domain.com)

The search results is positive. 

Is this still a permission issue?

Thank you for testing, Yevhenii.

I’ve searched for the error and found out that this issue is related to a bug:

Please, click on “This affects my team” and also watch to receive updates.

Angélica, thanks for trying to help. I'm unable to add myself to watchers. And I'm unable to add myself to affected customers. Probably for some permission reasons. 

But I want to add some detail about described workaround.

When the error message appear, click OK and start typing the username - this way isn't workable in my case. Because when I enter next symbol the same message appears again.

And one more thing. This ticket was created almost half year ago with the minor priority and assigned to no one. But described issue at least make searching uncomfortable. And makes it impossible for the new users like me )) Is it possible to grade up it status or to assign to someone?

Reading more details and also the comments from a ticket that was linked to the bug, the customer resolved by changing the key of the project.

As a test, can you check if you face this issue when only searching for the assignee, without selecting a project? Try the basic search only selecting an assignee.

Also, try to search for assignee on different projects.

If it happens on a specific project, if possible, share the project key with us, so we can try to replicate here and try to understand what is causing,

On the ticket that I mentioned, the key was TRUE and changing to TRU fixed the issue.



Unfortunately I don't have ability to attach video example of the actual behavior. But in all suggested cases issue is appears in all projects. And even if no project or additional search criteria is selected anyway issue present

Thank you for the details, Yevhenii.

We need two more information to investigate it further.

While trying to search, please open the developer tools on your browser and check if it will show any other error.

Also, let us know the date and time and your timezone, so once we receive your response, we can check our logs and filter by the time you tested and search for more errors and details.

Steps:

I open some ticket

Click on Lense icon on left rail

Click on "advanced search for issues"

And first event i've meet is 422 "The request was well-formed but was unable to be followed due to semantic errors." after POST on https://analytics.atlassian.com/analytics/events - 422 herments.ts:218 script

then when I trying to enter something in the assignee field I get 403 You are not authenticated. "Authentication required to perform this operation". After GET on https://medsymphony.atlassian.net/rest/api/latest/groupuserpicker?showAvatar=true&query=a&_=1575528342920

console shows:

Screenshot_45.pngMy date of the search is a 5 of december 2019 8:40 - 8:50 GMT+2

Thank you for the screenshots and information. I found one error on the logs but it doesn't help to figure out what is the cause.

The Uncaught TypeError might be related to some add-on. Can you please ask for the admin to check the list of the add-ons and let us know the ones you are using? So, I can install here and test if the same issue happens.

I believe I didn't ask you before but have you tested using another browser or incognito mode? Some extension on the browser may cause issues, so it's important to test. 

Hello :) Admin told me that we only have HipTest from add-ons.

As for browsers I've tested in incognito and on different browsers. I'm using Google Chrome as a main browser and Opera as a secondary. But not only I have such a problem in our team. And I noticed that those who have a that problem have an operating system lower than Windows 10. In my case it W8.1

Could this somehow affect?

Hello Yevhenii,

Thank you for all your help with the tests. 

We were able to test and replicate the same behavior here and the issue is related to the first assumption that is the Browse users and groups permission.

We removed all groups from the permission and when we type the first letter, it shows the same error:

no-browse-user-permission.jpg

Also, the errors on the developer tools show 403 forbidden when trying to search for users, which means that is related to a permission issue.

Please, ask your administrator to go to Jira settings > System > Global permissions and add permission to Browse users and groups. They can add a group where you are a member of or also, add you to a group that already has permission.

For further details about the permission and the issue, please check the documentation below:

Regards,
Angélica 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you