Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Show tickets where user is not present in multi user picker field

I would like to create a filter where all issues where I am not present in the "Phase 1 Local Approvals" field (multi user picker field).


The following JQL does not work:

"Phase 1 Local Approvals:[User Picker (multiple users)]" not in (xxx)

xxx is my user ID


However the opposite works fine (shows issues where I am present in that field):

"Phase 1 Local Approvals:[User Picker (multiple users)]" in (xxx)


Could this be a limitation from Jira?

2 answers

1 accepted

0 votes
Answer accepted
Trudy Claspill
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 23, 2023

In what way is the JQL not working?

When you have a field that can have multiple values if you want to find the issues where the field does not have a specific value and you also want the issues where the field has no value at all, then you need two criteria.

"Multiple User Picker[User Picker (multiple users)]" not in (xxx) or 
"Multiple User Picker[User Picker (multiple users)]" is empty

With a multi-select list when you use the operator "not in" the comparison between your specified values and the values in the field occurs only when the field actually contains values. If the field is empty, no comparison can be done, and so the issues with the empty field are not included in the result. You have to add the second criteria to also get the issues that have no value in the field.

This solved the problem. I was not aware that "not in" should be used only when the field has a value.

Thank you very much for the help. 


My guardian angel, helping me out with yet another issue I was having :D

I just tried the following with similar results.


JQL that works:

"Phase 1 Local Approvals:[User Picker (multiple users)]" = currentUser()


JQL that does not work:

"Phase 1 Local Approvals:[User Picker (multiple users)]" != currentUser()


Note that in both cases the green checkmark next to the JQL function is present.

Suggest an answer

Log in or Sign up to answer
Site Admin
AUG Leaders

Atlassian Community Events