Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Same sub-task displayed twice under a parent issue Edited

Hi Team,

 

We are facing a weird issue since last week. Some sub-task displayed twice (same key & description) as different sub-task under the parent issue. When we log work in such sub-task, in both this gets reflected.So the parent issue effort also duplicating as effort from both sub-tasks are being considered.  If i delete this sub-tasks both disappears from the parent. 

If i search with the sub-task id only one issue is displayed,in db also only one issue exists. If i search with parent id also in search result only the non-duplicated sub-task list is shown but when we open the parent task some sub-tasks are shown twice.

 

Any idea how to solve this? It's not happening always but many jira projects are facing this issue since last one week.

 

Thanks

Shilpa

3 answers

1 accepted

0 votes
Answer accepted

We were having this issue too.

Just to follow up on this with a solution, we updated to 8.2.1 and are no longer experiencing the problem. Methinks it was one of the items fixed between 8.0.0 and now.

Thank you for sharing your experience, @David Clark

In fact, I was not able to found any reported bugs about this behavior, however, I think it's worth check if I'm able to reproduce it in the version you mentioned, although we don't have more details and logs about the scenario to reproduce it.

Thanks again for the feedback!

Like David Clark likes this

Hi David,

 

You meant Jira 8.2.1?

That's right. I should also mention we're on Jira Server.

I tried the search indexing approach mentioned here, and then ran the database integrity checker, neither of which seemed to work while we were on 8.0.0 (or some version near that).

Then, we noticed there was an update available and went ahead and applied it. No more duplicated subtasks!

But our Jira is 6.4 and we are in the process of upgrading to Jira 8. So 8 is also not enough to solve this right?

I haven't done extensive testing so I can't be sure. All I know is that we were on version 8 when we first encountered the issue, and updating to 8.2.1 seemed to fix it.

0 votes

Hello Shilpa,

Have you tried to perform a background re-indexing of your Server instance in order to ensure the integrity of your index? Check the documentation below for more information:

Search Indexing

Also, I would recommend you to try the integrity checker after the re-indexing is finished:

Using the database integrity checker

Let me know if one of the options above worked for you.

0 votes

Hello everyone,

We have this problem as well in our system (server based, Jira 8.6.1). Re-Indexing doesn't help further. Any other tips to solve this problem?

Thank you for your support.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you