SVN subversion plug-in configuration

I'm running a pilot project on my laptop where I have a Visual SVN server instance running, as well as JIRA. I have installed the JIRA subversion plug-in and configured it for both the online JIRA testrepo and my own repository, they both show as "active" in the plug-in admin view, but commits with issue tags in the commit comments do not show up for either repository.

I'm pretty sure it is me doing something silly with the configuration, but after days, I'm at a loss. I made two screen-shots, one of the JIRA plug-in configuration page and one of a web-browser accessing my svn trunk to show that its up and the address, but I'm not sure how to share those screen-shots with you. --> Shared via DropBox
https://www.dropbox.com/s/rf4lf0gnt8hlfu7/JIRA%20support%202.png
https://www.dropbox.com/s/kr1iirqvjys1zh0/JIRA%20support%201.png

If anyone could provide some insight that would be great.. I need to figure this out so I can confidently roll out on our domain server.

5 answers

1 accepted

It now works, but I found several un-clear pieces of information in the install notes on the plugin web-page. My biggest grief is that there are no instructions about how to determine actual location of a folder. To me, listing a location as "$JIRA_HOME" does very little.. even a single sentence hint about how to resolve such addressing would be helpful. I realise that most people who administrate this type of software would probably know.. but I didn't.

unclear/incorrect? -->

It notes "In JIRA 4.4 and above, this is set in $JIRA_HOME/jira-config.properties" --> my install of latest JIRA this file does not exist.. The "home folder" can be seen by logging on as administrator, and under "system" drop down select "General Configuration" and scroll towards the bottom.

Since that file did not exist, I edited and added the line to the jira-application.properties file instead, despite the warnings in that file. (The line I added is: jira.option.ignore.url.with.key=false) (For good measure I created a text file named jira-config.properties with that line as well, but I did this AFTER the service had been restarted, so I'm not sure if that is why my svn link is now working?)

The instructions also make a huge point about how you have to check that "the current user has the View Version Control" permission, however, when I go to look at the default project permission scheme and the global permission schemes, there is NO SUCH OPTION.. So how can I configure this? -this is still, true, even now when I CAN see the revisions as a normal user, there is still no option to configure "View Version Control" as a permission?

I also deleted the folder where the svn revisions are stored. I tried just deleting the files (one section of the instructions say to delete the files and restart), but just deleting the files did nothing. Deleting the folder, along with the file edit desrcibed above plus a re-start was what finally fixed it for me.

I am having the same problem and could not see "View Version Control" permission. How was this problem resolved?

Hey Christian, thats what I tried first, but it didn't work so I tried to change it to what is in the screen shot, but that also doesn't work.

The other thing is, when I go to Permission Schemes -> Add Permissions, the "view version control permission" is not in the drop-down list of permissions to choose from, so maybe that is/was the only problem I have?

How can I add that permission to my default permission Schemes? Do I need to edit a file to get this value in the drop-down box?

Hey,

so you don't even see the tab on your view issue screen? . If you select your default permission scheme it should look sth. like my attached screenshot.

There you should select the view version control and "add" yourself or a group you belong to...

Attached are two screen shots, one for my global permissions screen, and one from my Permission Schemes - Default Permission scheme, I do not have the option you have circled in my list.. by the way, I really appreciate your time here!

And since pictures are a thousand words, if I go to a project view, I have an error message for the test repo and a "no subversion entries for this issue yet" on one of my real projects. Note: I have multiple svn comitts with "THERMVIEW-1" as part of the commit comment/description.

Also, now when I go to the subversion page, I have an error message on the QOREX trunk configuration: Status: Inactive (svn: E160006: No such revision 141337 svn: E175002: PROPFIND of '/svn/main_trunk/!svn/vcc/default': 500 Internal Server Error (https://kjellims-laptop.qorex.com))

I really think it must have something to do with some tags/fields in the setup or the address to the trunk. In my first post, I show that if I navigate to the /svn/main_trunk and log in, I see my repo, I use the same user name qorex\Kjell Ims and password to log in via the web-browser as I used when I configured the plug-in.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

94 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you