SSL proxy for jira and confluence applications on same domain (jira without context path)

Mizan Community Champion Jul 04, 2017

I have jira and confluence running on separate tomcat on the same server machine

jira : www.example.com 
confluence : www.example.com/wiki

I have made the configuration and SSL works for jira but not for confluence.

When I try to go to https:www.example.com/wiki, i get a page not found exception

httpd.conf

ServerName example.com

<Proxy *>
    Order deny,allow
    Allow from all
</Proxy>

SSLEngine               On

SSLCertificateFile      /etc/ssl/certs/mydomain_com_with_chain.crt
SSLCertificateKeyFile   /etc/ssl/private/mydomain_com.key

ProxyPass               /       http://myserver:8081/
ProxyPassReverse        /       http://myserver:8081/

ProxyPass               /wiki       http://myserver:8082/wiki
ProxyPassReverse        /wiki       http://myserver:8082/wiki

 

The server.xml configuration is correct with the connector having proxy parameters

 <Connector port="8081"
               maxThreads="150"
               minSpareThreads="25"
               connectionTimeout="20000"
               enableLookups="false"
               maxHttpHeaderSize="8192"
               protocol="HTTP/1.1"
               useBodyEncodingForURI="true"
               acceptCount="100"
               disableUploadTimeout="true"
               scheme="https"
               proxyName="example.com"
               proxyPort="443"
               secure="true"/>

Can someone please point out the problem here . I suspect it is because jira does not have a context path. However, I cannot have a context path for jira. Any suggestions highly appreciated.

1 answer

1 accepted

Mizan,

What if you add a proxy for /wiki in before /

ProxyPass /wiki http://myserver:8082/wiki
ProxyPassReverse /wiki http://myserver:8082/wiki

ProxyPass
/ http://myserver:8081/
ProxyPassReverse / http://myserver:8081/

Also, make sure you have ProxyPreserveHost On

Cheers,

Lars

Mizan Community Champion Jul 06, 2017

Hi Lars,

Thanks for your response.

Unfortunately, this does not help . I made the changes and restarted apache.

I am checking the URL in Chrome incognito mode

Mizan Community Champion Jul 17, 2017 • edited

Hi Lars,

Your answer was correct, I had not removed my old configuration was being included from a different file.

However, Confluence now shows us a different view. Do you know how this can be solved.

confssl.jpg

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

496 views 6 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you