Replies not coming through in Mobile Connect

Hi,

Is there something special I need to do to make the notifications appear in iOS? None of the replies seem to come through at all. The ping is returning successfully, but nothing happens in the app.

Thanks,

Rich.

11 answers

1 accepted

This widget could not be displayed.

Yes I did - it was an issue with conflicting frameworks. Try removing all your dependent frameworks and using the ones supplied with JIRA, that fixed it for me.

Can you enumerate on what Frameworks to look for? Are there common 3rd party integrations that can cause this (e.g. TestFlight)?

E.g. SBJSON might conflict with iOS5's NSJSONSerialization. We can't remove that.

All I can decipher that is a possible source of conflict:

1. SBJSON

2. PLCrashReporter (the crash reporting framework)

3. Reachability

Is there anything else? Perhaps a list provided by Atlassian of popular 3rd party integrations, where those 3rd party SDKs create conflicts?

I have the same issue... no issues if I call http://jira.domain/jira/rest/jconnect/1.0/issue/updates?sinceMillis=1364337750447&uuid=***&apikey=***&project=ET

I get {"sinceMillis":1364340276368,"crashReportingDisabledInJIRA":false,"issuesWithComments":[]}

Which frameworks I have to remove..? I have no idea :(
Thanks for you help in advance! :)

This widget could not be displayed.

I've been looking into it further - basically it just never receives any of the comments posted in the JIRA interface, it always has a newIssueCount of 0. My comments in JIRA onDemand are assigned to all users. Any idea what could be happening?

This widget could not be displayed.

OK - I've confirmed that the json being sent just doesn't include any of the new comments or feedback. Going to https://[myappname].atlassian.net/rest/jconnect/1.0/issue/updates in a browser after adding comments gives the following result:

{"issuesWithComments":[],"sinceMillis":1336065726789,"crashReportingDisabledInJIRA":false}

This widget could not be displayed.

Other things I've now tried:

Going through settings, enabling notifications, removing and re-adding frameworks in xCode... a friend who uses JIRA told me that OnDemand is often broken and some features only work with the desktop version. Could that be the issue? Has anyone had experience with OnDemand features not working?

This widget could not be displayed.

I am having the same problem. Replies are not getting back to my App and also Crash Reports are not beeing sent.

This is my configuration code:

JMCOptions *options = [JMCOptions optionsWithUrl:@"https://XXX.atlassian.net/"
                                          projectKey:@"XXX"
                                              apiKey:@"XXX"
                                              photos:YES
                                               voice:YES
                                            location:YES
                                      crashReporting:YES 
                                       notifications:YES
                                        customFields:nil];
    
    [[JMC sharedInstance] configureWithOptions:options];

Did you manage to solve it?

This widget could not be displayed.
Nick Pellow Atlassian Team May 19, 2012

To get to the bottom of issues like these, it is best to run the JMC SDK with Debug logging enabled.

All that needs to be done, is to set the JMC_DEBUG flag as a pre-processor macro. A screenshot and instructions of how to do this in Xcode is available in step 11 of the README: https://bitbucket.org/atlassian/jiraconnect-ios .

Cheers,

Nick

This widget could not be displayed.
I only needed to remove frameworks that came with jira. I didn't need to remove and re-add anything else.
This widget could not be displayed.
Nick Pellow Atlassian Team May 20, 2012

Hi Rich,

Can you please confirm which version of JMC you are on - default/HEAD ?

Also, by "frameworks that came with jira", do you mean the libraries in the JMCClasses directory ?

And if you have any ERRORS or Log messages with the JMC_DEBUG flag set, that would be very useful to help us track down the cause of this.

Cheers,

Nick

Sorry for not being clear - yes, I had various libraries already in my project (such as reachability and crashreporter), and removing the old ones and adding the ones that came with the JMC classes fixed the problem for me. My code is working now so it would be tricky to be sure if there were errors, but I'm pretty confident there weren't, and that the ping was returning a 'nothing new' result every time.

So it seems Reachability and CrashReporter are typical conflicts that if the JMC versions are kept and the other versions removed, folks can get replies to come through.

What doesn't make sense to me however, is why the web service call that we can paste into our browser, also shows that there are no updates. Shouldn't that at least show results when I invoke that web service call in my browser?

Nick Pellow Atlassian Team May 21, 2012

Thanks for the updates, guys.

I will try and reproduce this at some stage and try and work out exactly what is happening. I would have thought Xcode would not be able to build the project if those frameworks are duplicated.

If you find anything more, please update this answer. Cheers,

Nick

I concluded that I must just have the wrong URL or was misunderstanding what was supposed to be returned, but yes that confused me as well.

Just to clarify Nick - I wasn't duplicating frameworks or lib classes, I just didn't import all the JMC libs because I assumed the ones I was using were the same, when they actually weren't.

Oddly, JMC replies started coming through for me late evening (EST) on May 21st. I'm getting them on my phone now, even though I've not added or removed any frameworks! I wonder if a back end change to JIRA OnDemand was rolled out that fixed part of the server-client interaction here.

Nick Pellow Atlassian Team May 22, 2012

Hi Sohail,

I believe this could have been caused by JIRA needing a re-index of issues.

This may have happened overnight for your particular instance.

Thanks for following up. There was nothing else in the code that I could that may have caused this.

Cheers,

Nick

I have the same issue... no issues if I call http://jira.domain/jira/rest/jconnect/1.0/issue/updates?sinceMillis=1364337750447&uuid=***&apikey=***&project=ET

I get {"sinceMillis":1364340276368,"crashReportingDisabledInJIRA":false,"issuesWithComments":[]}

Which frameworks I have to remove..? I have no idea :(
Thanks for you help in advance! :)

This widget could not be displayed.

I've been battling this for a week as well, going thru all the same steps to try to resolve the issue that you all did, but nothing has worked.

2012-08-11 15:32:01.143 Angry Nerds[39663:c07] 61 +[JMCRequestQueue sharedInstance] queue at  /Users/ajones/Library/Application Support/iPhone Simulator/5.1/Applications/A3B48231-F9D2-483F-8525-C2CFC92CEBB0/Library/Application Support/JMC/JMCQueueIndex.plist
2012-08-11 15:33:51.193 Angry Nerds[39663:c07] 55 -[JMCPing sendPing] Retrieving notifications via: https://[omitted].atlassian.net/rest/jconnect/1.0/issue/updates?sinceMillis=1344724321113&uuid=[omitted]&apikey=[omitted]&project=JMC
2012-08-11 15:33:52.670 Angry Nerds[39663:c07] 73 -[JMCPing didReceiveComments:] Time JIRA last saw this user: 2012-08-11 22:33:52 +0000
2012-08-11 15:33:52.673 Angry Nerds[39663:c07] 113 -[JMCPing connectionDidFinishLoading:] Flushing the request queue

I've got JMC_DEBUG=1 set in my pre-processer macros but I'm not seeing anything else.

This widget could not be displayed.

I have exactly the same issue here. I'm using a pretty much stock iOS app configuration, apart from the addition of box2d. Otherwise I've just added the frameworks and libraries that are recommended in the JMC install instructions.

I also do not get any feedback received in the app, although tickets are opened.

I don't think that it's a frameworks issue.

This widget could not be displayed.

Same thing here. Tickets are being created but no feedback when a JIRA user comments on a ticket.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

121 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you