Remove the "None" option from radio buttons

When creating radio buttons for the page where you resolve or close an issue, the system automatically produces a radio button called "none". Is there a way to remove this option?

7 answers

This widget could not be displayed.

If you need the user to select a value for the radio button (i.e. the field is mandatory) and just want to remove the NONE, you can set it to REQUIRED in the field configuration and the NONE option will disappear (at least in JIRA 6.0.1).

As an administrator, click the COG icon to the left of your avatar, choose issues, then field configurations and then against the field you want to change, click the Required link under the operations column. Now the radio button will be mandatory and the none option disappears.

Many thanks, that worked well with Jira 5.1.3

This widget could not be displayed.

We've got a couple how-to's on this. It's a fairly popular customisation:

Those aren't for radio buttons, but it's a similar configuration. Also I haven't verified those in 4.3 and 4.4. Is that enough to get started? Let me know if I should write up a similar specific one for radio buttons, or if you get stuck.

This widget could not be displayed.

You have to make the field required in order for none to disappear, others may able to be comment on a hack or something, but out of the box none appears because the field is not required.

This is a problem for us often as well.

This does not appear to work. We made the feild required, and set the default to another option. None still appeared.

This widget could not be displayed.

In v4.3.3

I also had to remove 2 extra lines in the top.

============


<input$!{checked} class="radio" id="cf-${customField.id}" name="${customField.id}" type="radio" value="-1"

<label for="cf-${customField.id}">$i18n.getText('AUI.form.label.none')</label>

============

This widget could not be displayed.

I’m trying to remove ”none” from radio button field but it’s not working
I removed these two lines from edit-radio.vm file

#if ($hadAnyValidOptions == false)

<input checked="checked" class="radio" id="cf-${customField.id}-none" name="${customField.id}" type="radio" value="-1" />

<label for="cf-${customField.id}-none">$i18n.getText('AUI.form.label.none')</label>

#end

And restarted the server..

What more to do? Did I miss something?

I don’t want to make these fields required

It worked to remove “none” from select list fields (How to Remove 'NONE' from a Select List Custom Field)

This widget could not be displayed.

You have to make the field required, then the 'none' won't be there anymore.

This widget could not be displayed.

Making the field required is not letting the issue created. The required field containing screen is attached to the state that comes later in workflow.

But This workaround not letting the issue create.

Behaviors (part of ScriptRunner) can solve this scenario.  You can set the field to Required only on a specified transition screen or state.

Adding behaviour didnt hide "none" option in my case

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

78 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you