Morning Everyone,
When I shutdown VM and use another IP to carry VM, JIRA software cannot read h2db already, do you have any advise? Do you have method I can retrieve my project works?
Thanks everyone
80355328 is h2db.mv.db file size
------------------------------------------------------------------------------------------
Error Log:
Caused by: java.lang.IllegalStateException: Reading from cache:nio:C:/Program Files/Atlassian/Application Data/JIRA/database/h2db.mv.db failed; file length 80355328 read length 768 at 84646650 [1.4.185/1]
at org.h2.mvstore.DataUtils.newIllegalStateException(DataUtils.java:773)
at org.h2.mvstore.DataUtils.readFully(DataUtils.java:443)
at org.h2.mvstore.FileStore.readFully(FileStore.java:98)
at org.h2.mvstore.Page.read(Page.java:189)
at org.h2.mvstore.MVStore.readPage(MVStore.java:1830)
at org.h2.mvstore.Page.getChildPage(Page.java:216)
at org.h2.mvstore.Cursor.fetchNext(Cursor.java:150)
at org.h2.mvstore.Cursor.next(Cursor.java:50)
at org.h2.mvstore.MVStore.readFileHeader(MVStore.java:696)
at org.h2.mvstore.MVStore.<init>(MVStore.java:357)
at org.h2.mvstore.MVStore$Builder.open(MVStore.java:2769)
at org.h2.mvstore.db.MVTableEngine$Store.<init>(MVTableEngine.java:162)
at org.h2.mvstore.db.MVTableEngine.init(MVTableEngine.java:98)