Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Progress is not 100% for Done task

For the sub-tasks that are in Done statusCategory and have resolution set, i see that in some cases progress% is not 100%.

One of the anomalies that i notice for such sub-tasks is -

1. There is no original estimate defined

2. Developer did not log any time against the subtask

Is there a way to make the progress % as 100% even though there is no work logged against such tasks?

1 answer

0 votes

Hi @Vishal Biyani 

Just to confirm...

  • You have Subtasks below a Task (or similar standard issue type)
  • The Subtasks are all in a "Done" status with a resolution set
  • The % does not say 100%

...?

---

The estimates / time logged shouldn't impact the % completion of the Subtasks in my experience - it's a count of Subtasks completed.

A few things you can check:

  • Confirm all the issues have resolutions. On the parent issue, click options (3-dots icon) just above the % value and select View in search
  • Check the percentage and try to work out if it represents an exact number of Subtasks.
    • If it does, it'll give you an idea of how many are missing from the % and you can look for anomalies (not just time-based ones)
    • If it does not, it's more likely a data issue. Let us know how you have Jira setup for Parents/Subtasks in more detail

---

Let us know how you go. Feel free to provide us details from the things to check above, with any supporting screenshots!

Ste

@Stephen Wright _Elabor8_  Thanks for your response.

The structure that i am using is:

Initiative -> Epic -> Standard IssueType -> SubTask Issue Type.

I search the sub-task issues under Story as you suggested. I have 4 subtasks underneath the Story. Added Progress column in results window.

What is notice is -

  1. All the sub-tasks are in Done category with Resolution = Done set.
  2. 1 subtask has no Progress bar (original estimate=0m, No remaining estimate, No Work Log added to this sub-task)
  3. 1 subtask has 100% as remaining estimate is 0
  4. Other 2 subtasks are not 100% complete as they have remaining estimate

What should i do in order to get progress = 100% for #2?

See screenshot below. Any suggestions to fix this anomaly at sub-task level will be really helpful.
screenshot.JPG

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you