Problem with required fields

Hi,

I need to have some fields required so I configured this fields as "required". The problem is that in other screens that those fields are not shown I get an error about those required fields.

I have read some answers done more than a year before, that recomended to use validatos instead of this required fields but the validator: "Field has been modified Validator " doesn't work as well. So it's not possible to require to fill fields in the OnDemand version? How can this be possible that more than a year after this is still no fixed?

Thanks

4 answers

1 accepted

2 votes

That is correct behaviour. If you mark a field mandatory, then you have to give the user some way to enter the fields. That's the whole point of mandatory fields - you want the users to enter data.

If you want to do this in the workflow later though, then you need to make the fields optional, and use validators, as you've looked at in your second paragraph.

I've had no problems using "field has been modified" - it checks that the new value is different from the old one when you go through a transition, so I'm really unsure what you mean by "doesn't work". However, as you seem to want mandatory fields, I'd recommend a look at using one of the "Field is mandatory" validators instead

Hey Nic, 

Do you know why JIRA would allow the selection of a field being Optional or Required per Field Configuration if it is not going to apply, regardless?

I'm having the same issue - fields that are selected as Mandatory in 1 field configuration are showing as Mandatory in an unrelated field configuration. 

Do you know a way around that issue?

I am sorry, but that does not make sense.

Your first question doesn't say where the "allow selection" is happening, what field configuration has to do with it, or where "it is not going to apply" applies.  I've tried to take a guess, but I can't work out what you're talking about, there's not enough information.

Your second question has more context, but it appears to be describing something JIRA simply does not do.  Field configurations are separate entities, that's the whole point of them.  There are two ways to get to what you are seeing though - one is that another admin has set the mandatory flags, and the other is that you're looking at two projects and not seeing that they are using the same field config.

Maybe this will help clarify, Nic. 

I have 1 JIRA project that has 2 issue types: Task, and Bug. 

I have defined 2 separate Field Configurations: Task, and Bugs. JIRA allows me to do this. They are in the same Field Configuration Scheme, applied to my singular JIRA project. JIRA allows this, out of the box.

In Field Configuration 1 [Bugs], the 'Location' field is Mandatory. 

In Field Configuration 2 [Tasks], it is Optional. 

The intent is that they are treated differently between the 2 issue types. That is why there are Field Configurations. 

Although the field is Optional for Tasks, when I create a task it prompts the message that it is Mandatory (due to it being Mandatory for Bugs). 

This is all built in functionality for JIRA, so very odd that it wouldnt behave as selected. I will try the Validators option mentioned by Marian. 

That's wrong.  It's certainly not what it should be doing.  Makes me suspect that your field config scheme is not mapping them correctly.

Or it's a flow thing - when you create a task, does the screen show the red * for mandatory?

Yes, if it is on the screen the red indicator for it to be Mandatory and the message appears. 

Are you saying that JIRA should NOT allow multiple field configurations per project? I'm confused on which portion you're deeming wrong. 

 

 

No, sorry, I was not clear there.  I'm saying what you are seeing is incorrect behaviour if everything is configured correctly.

The red indicator shows that the field is set to mandatory by the field configuration, so we can forget my thought that it's "a flow thing"

I think we need to see your field configuration scheme and the project settings for it.

Nic,

'If it's configured correctly' was the problem. Had all of my schemes savvy, but didn't apply them to the project. 

o.0 So sorry for the back and forth but thank you for your insight and help!

Ah, fantastic you've found it!  I'm glad my ramblings lead you to go back over the config.  I must admit, getting the right scheme applied is something I get wrong all the time too.  I've got used to checking and re-checking lots of times.

0 vote
Joe Pitt Community Champion Dec 15, 2013

I thought the one demand had the jira-suite utilities plugin. It has a validator

Dear Nic,

I haven't the "Field is mandatory" validato in the OnDemand version of Jira, do you have it?

Regarding the "field has been modified" I have an open support ticket because it doesn't work. Also the technician from Atlassian that is dealing with my case said that has the same problem and has opened a case with the third-party company that developed the validator.

And regarding the required fields, I want a field as required, but I don't want the system to required a field that is not on a screen, so that is why we have the possibility to choose different fields for different screens. So I really think that this functionality is not working properly.

So at this point I have no way to work with mandatory fields.

Thanks for your help

Everything is working correctly, barring the possible problem with "field has been modified"

You need to stop thinking of mandatory stuff having ANY relationship with screens. It does not. A mandatory field is mandatory AT ALL TIMES, so if you set it that way, you MUST put it on a "create" screen. Stop thinking about fields, screens and mandatory flags together, it is not helping you.

You absolutely do have a "field is mandatory" validator in OnDemand - every single OnDemand install I've looked at has it. From memory, it's probably "field is required" instead of "mandatory", but it's definitely there. You might need to enable plugins in your account though - the Jira Suite Utilities is the one I use.

You might also want to explain the problem you have with "field modified" - it's working fine for me, both OnDemand and other Jira's I use.

Hi,

I have enabled the Jira Suite Utilities Plug-in and now I have the "field is required" validator, and it is working.

Thanks

Hi Marian,

Thanks so much for asking this question - I've bumped into the exact same problem. How did you enable the Jira Suite Utilities in OnDemand? Can anyone do so?

Daphna

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,308 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot