Problem with proxy-setting in JVM_SUPPORT_RECOMMENDED_ARGS after update

I made an update from Jira 64-bit 5.1.7 to 5.2.2 and Jira won't start.

I discovered that the problem is related to the JVM_SUPPORT_RECOMMENDED_ARGS variable in JIRA_HOME/bin/setenv.sh.

It read: JVM_SUPPORT_RECOMMENDED_ARGS=-Dhttp.proxyHost=proxy.company.com -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=**.internal.company.com|*.company.net|localhost|127.0.0.1|192.168.169.*

The logfile /usr/local/jira/std/logs/catalina.out reports:

eval: 1: 127.0.0.1: not found

eval: 1: *.company.net: not found

eval: 1: localhost: not found

eval: 1: 192.168.169.*: not found

If I reduce the nonProxyHosts to one entry so that there is no pipe symbol, Jira will start.

The variable reads now: JVM_SUPPORT_RECOMMENDED_ARGS=-Dhttp.proxyHost=proxy.clausjuergens.de -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=*.company.net.

The problem does not occure with Jira 5.1.7 and all prior versions we run.

We need multiple exceptions for the proxy use. What delimiter should be used now? Or is there a bug that the pipe symbol is interpreted as a shell pipe though it should not be.

Thanks in advance,

Steffen

5 answers

1 accepted

This widget could not be displayed.

Hi Steffen,

You can try to Escaping it with "/"

  • -Dhttp.nonProxyHosts=\".clausjuergens.de|.cleb.net|localhost|127.0.\"
Hope it helps

KM

This widget could not be displayed.

I surrounded the proxy exceptions by escaped quotation-marks and now ist works.

-Dhttp.nonProxyHosts=\"exception1|exception2\"

So the whole variable setting looks like this:

JVM_SUPPORT_RECOMMENDED_ARGS="-Dhttp.proxyHost=proxy.company.com -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=\"*.internal.company.com|*.company.net|localhost|127.0.0.1|192.168.169.*\""

The asterisk (*) was not the problem. It was the pipe (|).

Thanks for your suggestion and sorry for my typo (**)
- Steffen

This widget could not be displayed.

I was just about to hit the post button when I noticed you had "Dhttp.nonProxyHosts=**.internal.company.com"

This could just be a typo in the forum post but I don't think you should have the two *'s there, I think it should be "Dhttp.nonProxyHosts=*.internal.company.com|"

I had issues with the proxy settings as well but, I don't think it was the same issue your having but, I think my solution might help. Our solution was to move the setting to the catalina.properties file instead of using java args. The list of config options follow:

http.proxyHost=0.0.0.0
http.proxyPort=8080
https.proxyHost=0.0.0.0
https.proxyPort=8080
http.proxyUser=<Proxy User>
http.proxyPassword=<Proxy Pass>
http.nonProxyHosts=*.local|devmachine|someothermachine

#For Active Directory Auth
http.auth.ntlm.domain=<domain>
http.proxyAuth=ntlm

You may not need to set both the http and https proxy settings.

This widget could not be displayed.

For me, it seems that you forget the Quotes:

JVM_SUPPORT_RECOMMENDED_ARGS=" "

or

JVM_SUPPORT_RECOMMENDED_ARGS="-Dhttp.proxyHost=proxy.company.com -Dhttp.proxyPort=8080 -Dhttp.nonProxyHosts=**.internal.company.com|*.company.net|localhost|127.0.0.1|192.168.169.*"

This widget could not be displayed.

The only way I have been able to get wildcards working in my nonProxyHosts settings for either JIRA or Confluence running on CentOS was to move them to catalina.properties as per Jason Henlers suggestion. Even Atlassian Support couldn't help me and told me to talk to Oracle.

And even then, wildcards on the nonProxyJosts lines are ignored on JIRA (6.2.3), but not for Confluence.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

106 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you