Problem with custom Avatars in Jira

After creating and uploading some customer avatars the avatars in the activity screen show up as red x's. It's not a huge issue but I'll be deploying Jira and fisheye to the rest of my department soon and I'd like it to work.

1 answer

1 accepted

This widget could not be displayed.

Normally this happens when the avatar isn't in the right path and the Jira can't find it to show on the user interface. So, the avatar could have been erased from the avatar directory or the file could have the name changed.

By default the folder location is here:

/var/atlassian/application-data/jira/data/avatars

Thanks for the quick reply. I just checked the path and they are there. The avatars works within everything else except the activity screen. I just went through the links and noticed that it was pointing to localhost. This isn't going to work on remote machines. I had to go into Administration, then system, and general configuarion. Then change the base URL to the DNS name of the Jira server from local host. Now avatars come up but the default avatars, not the custome ones. Again, this is only in the activity screen. Any suggestions? Thanks for taking the time.

Right now, in activity stream you have the default avatar and in other places the avatars are the uploaded images?

That is correct. In the activity screen they are the default and the user profile screen and the Issue navigator for instance the custom one shows up.

Woah... There's something buggy about this... You could do two things I believe:

1. Verify if Jira is asking for a reindex.

2. Assign to the user a default avatar again and then the custom one to see if it is working.

P.S. In last instance you could a Jira restart, but I hate to do that, so let's try to figure out what could be possible wrong.

It wasn't asking for a reindex but went ahead and did one anyway. No joy there.

I assigned a different avatar from the default choices and it worked perfectly. I then reassigned the custom avatar and just like before it works everywhere else except the Activity Stream. Does the activity stream look somewhere else for it's avatars?

Your base URL is probably wrong - check admin -> general config. The activity stream is a good canary for problems with the base url.

I found this about what @Jamie said:

http://confluence.atlassian.com/display/JIRAKB/Avatars+Are+not+Correctly+Shown+in+Activity+Stream+Gadget

Have you added the port to your URL Base? Someone's problem was that.

Like @Jamie said, are you positive about the Base URL?

A HUGE that you for that link. I had the FQDN name as the base URL. Turns out just like Martin in that link you sent I just had to put in the netbios name and it worked! Doesn't make much sense as to why but it's working now. Thanks so much!

Also attempt to stop/start since some items get rebuilt.

Glad it worked Chuck! You're that welcome ;)

Sorry for the type-o. I ment Thank you!!not that you...LOL!!

Remember to mark the answer as correct in order to help other users.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

196 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you