Permissions error accessing a project as the administrator.

I have a project that I am using as a sandbox to develop workflows and test importing issues. Somehow when I attempt to access the Overview of the project, I get an error reading "Permission Violation It seems that you have tried to perform an operation which you are not permitted to perform. If you think this message is wrong, please contact your JIRA administrators." with a link to contact my own e-mail address. I'm not aware of anything that changed regarding permissions, and I'm not able to find a way to recover from this state. This is potentially causing whole projects to wipe out randomly if I don't understand what's causing this, so I need to know what happened, or how to prevent this state, or at the very least how to recover from this state.

It also looks like this has happened to others:
https://answers.atlassian.com/questions/64867/my-project-has-disappeared-i-can-only-see-it-in-admin

https://answers.atlassian.com/questions/89540/a-created-project-disappeared-from-dashboard-and-no-access-to-all-issues-of-project

But I can't find an applicable answer for how to deal with this. My permissions are identical between the disappeared project and other projects that remain. They are each using the same scheme.

2 answers

1 accepted

3 votes
Accepted answer

The answers on the links you've found pretty much cover this situation.

First, read the permission scheme for the project. Specifically, check what the "browse project" line says

Second, look at your profile. Do your groups or roles match any of the lines in "browse project"?

I'm 99.99% sure that you'll find your profile does not meet the requirements to browse the project. How you got there and how to prevent it happening is a different kettle of fish, but you need to know what is breaking it before you can think about fixing the root cause.

Adjusting the user group/permissions allowed access to the project again.

This is good in that it solves the problem, but other issues remain. The permission scheme did not change, and as I said it was the same scheme for other projects, and I was still able to access the other projects just fine. From that it would appear that there is an issue with respect to that with permissions changing without input, permissions not being respected globally, or perhaps a combination of the two.

We're in this boat as well, except the users who can see the project are unable to see the 'Permission Schemes' tab at all. Is there a way out? 

It's the same answer - check and set the permissions on the project to allow it!

My permissions are identical between the disappeared project and other projects that remain. They are each using the same scheme.

No doubt they are the same, but another area to look at in addition to what @Nic mentioned: do you have roles in the Browse Project permission in your permission scheme? If it is available, then check the project roles setup in the troubled project. Maybe the role(s) granted to you does not match the one that is set for the Browse Project permission?

The Browse Project permission had been set to a specific role that my admin user was not set to, and adjusting that is what resolved the problem.

HOWEVER it was the same setting across all projects and that setting had not been changed. (There are only two permission schemes and one is completely blank and unused.) I had also set the project roles settings to be identical across them as well. So with all of that being the case, my admin user should not have been able to see ANY of the projects at that time. I now know how to resolve the issue, but that doesn't help with understanding what caused it in the first place.

Did someone update the people/groups in the roles in use in the projects? Project admins can do that.

No. None of the permissions were changed. None of the peope/groups were changed. When this issue manifested itself none of these settings had been edited.

You're going to need to wade through this one line at a time. For each thing you cannot do, look at the permission scheme and try to work out who can or cannot do it.

I understand that. I have been able to resolve this instance of the issue as I stated above. Currently I have no access problems. My concern now is how did this happen in the first place, and how do I prevent it from happening again? If there is no answer then so be it and if it occurs again I will know how to deal with it, but knowing a cause would be preferable.

Well, if "adjusting the user/group permissions" fixed it, then the most likely explanation is that one of your admins did that before and broke it.

No one adjusted the permissions. There are two admins and neither of us changed those settings when this problem manifested. So from here I'll simply take the lesson for how to resolve an issue like this and if this manifests again I'll post here again with much more detail about the situation.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,935 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you