Not able to open Jira using HTTP protocol

Hi

I have installed Jira 7.6.1 and link to mySQL database after setting Jira using in-built database.

After linking to mysql, when I start Jira in browser, error 503 received.

 

Need your support to start configuring my project

6 answers

1 votes

In the end we found that $JIRAHOME/dbconfig.xml file had a leftover configuration line from when it was using the H2 database: <schema-name>PUBLIC</schema-name>

This should not exist for a MySQL database as such, so by removing this and saving that file, Biswajit was able to resolve this issue.

You can also use the Jira Config Tool in order to make sure that your dbconfig.xml is properly setup for your database type.   This might be one way to avoid this kind or problem too.

0 votes

Usually means Jira has not finished starting up, or it's failed for some reason.

What does the application log say is the problem? 

Defaults to <jira home>/logs/atlassian-jira.log , although you might also need to look at <jira install>/log/catalina.out

Hi

Thanks for your direction.

Copying the atlassian-jira.log for your reference and guidance.

2017-12-21 19:09:56,044 http-nio-8080-exec-1 ERROR anonymous 1149x1x1 - 10.3.2.143 /secure/errors.jsp [c.atlassian.instrumentation.Instrument] Unable to snapshot thread local operations (implementation of OpTimerFactory is not a ThreadLocalOpTimerFactory): null
2017-12-21 19:09:56,067 http-nio-8080-exec-1 WARN anonymous 1149x1x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:09:56,873 http-nio-8080-exec-2 WARN anonymous 1149x2x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:09:57,620 http-nio-8080-exec-3 WARN anonymous 1149x3x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:09:58,081 http-nio-8080-exec-4 WARN anonymous 1149x4x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:09:58,397 http-nio-8080-exec-5 WARN anonymous 1149x5x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:09:58,576 http-nio-8080-exec-6 WARN anonymous 1149x6x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:14:47,616 http-nio-8080-exec-7 WARN anonymous 1154x8x1 - 127.0.0.1 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:53:51,032 http-nio-8080-exec-8 WARN anonymous 1193x9x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 19:53:53,749 http-nio-8080-exec-9 WARN anonymous 1193x10x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp

Hi

Please find the details of what I have done

1. Install Jira 7.6.1 and MySQL 5.7.20 on my server

2. Did the initial jira set up using in-built databse

3. Did the configuration for my database in MySQL

4. Did the steps to connect Jira to my database

5. Test my database connection, below is output

Test Connection  ([Y]/N)? > Y
Attempting to connect to localhost:3306/jiradb
Thu Dec 21 21:07:26 IST 2017 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Connection successful!

6. Tried to open Jira using the HTTP request, get the below error:

jira01.sasken.com is currently unable to handle this request.

HTTP ERROR 503"

the URL changes to "http://jira01.sasken.com:8080/secure/errors.jsp"

 

In log, many times the jdbc connection issue error displayed.

Any pointer to the solution, please help

Thanks you in advance

0 votes

What does the error in the application log say is the problem?

Below are some lines from the end of the filee

 

2017-12-21 20:51:04,074 JIRA-Bootstrap ERROR      [c.a.jira.health.HealthChecks] We couldn't start JIRA
2017-12-21 20:51:04,074 JIRA-Bootstrap ERROR      [c.a.jira.health.HealthChecks] An error occurred while trying to start JIRA. We can't give you any more detail right now, we suggest checking the logs for more detail and contacting our support team.
    See our documentation for more information on contacting our support team and creating a support zip.
2017-12-21 20:51:04,074 JIRA-Bootstrap INFO      [c.a.jira.startup.DatabaseLauncher] Database transactions enabled: true
2017-12-21 20:51:04,074 JIRA-Bootstrap INFO      [c.a.jira.startup.DatabaseLauncher] Using JIRA's default for database transaction isolation level: 2
2017-12-21 20:51:04,082 JIRA-Bootstrap WARN      [c.a.jira.startup.DatabaseLauncher] JRADEV-23357: unable to select from the 'MovedIssueKey' entity.
2017-12-21 20:51:04,082 JIRA-Bootstrap ERROR      [c.a.jira.startup.LauncherContextListener] Unable to start JIRA.
com.atlassian.jira.exception.DataAccessException: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'jiradb.MOVED_ISSUE_KEY' doesn't exist
    at com.atlassian.jira.startup.DatabaseLauncher.cleanupDatabaseTableName(DatabaseLauncher.java:261)
    at com.atlassian.jira.startup.DatabaseLauncher.cleanupDatabaseTableNames(DatabaseLauncher.java:217)
    at com.atlassian.jira.startup.DatabaseLauncher.start(DatabaseLauncher.java:79)
    at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$postDbLaunch$2(DefaultJiraLauncher.java:150)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:304)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:199)
    at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:146)
    at com.atlassian.jira.startup.DefaultJiraLauncher.lambda$start$0(DefaultJiraLauncher.java:105)
    at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:31)
    at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:103)
    at com.atlassian.jira.startup.LauncherContextListener.initSlowStuff(LauncherContextListener.java:160)
    at java.lang.Thread.run(Thread.java:745)
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'jiradb.MOVED_ISSUE_KEY' doesn't exist
    at sun.reflect.GeneratedConstructorAccessor12.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
    at com.mysql.jdbc.Util.getInstance(Util.java:408)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3973)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3909)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2527)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2680)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2480)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2438)
    at com.mysql.jdbc.StatementImpl.executeQuery(StatementImpl.java:1381)
    at org.apache.commons.dbcp2.DelegatingStatement.executeQuery(DelegatingStatement.java:207)
    at org.apache.commons.dbcp2.DelegatingStatement.executeQuery(DelegatingStatement.java:207)
    at com.atlassian.jira.startup.DatabaseLauncher.cleanupDatabaseTableName(DatabaseLauncher.java:245)
    ... 11 more
2017-12-21 20:51:04,085 JIRA-Bootstrap INFO      [c.a.jira.startup.LauncherContextListener] Memory Usage:
    ---------------------------------------------------------------------------------
      Heap memory     :  Used:  115 MiB.  Committed:  479 MiB.  Max:  736 MiB
      Non-heap memory :  Used:   61 MiB.  Committed:   63 MiB.  Max: 1264 MiB
    ---------------------------------------------------------------------------------
      TOTAL           :  Used:  176 MiB.  Committed:  542 MiB.  Max: 2000 MiB
    ---------------------------------------------------------------------------------
2017-12-21 20:51:12,935 http-nio-8080-exec-1 ERROR anonymous 1251x1x1 - 10.3.2.143 / [c.atlassian.instrumentation.Instrument] Unable to snapshot thread local operations (implementation of OpTimerFactory is not a ThreadLocalOpTimerFactory): null
2017-12-21 20:51:12,989 http-nio-8080-exec-2 WARN anonymous 1251x2x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 20:51:22,523 http-nio-8080-exec-4 WARN anonymous 1251x4x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp
2017-12-21 20:55:33,477 http-nio-8080-exec-6 WARN anonymous 1255x6x1 - 10.3.2.143 /secure/errors.jsp [c.a.jira.security.JiraSecurityFilter] Rejecting security-sensitive request that bypassed Johnson filter: /secure/errors.jsp

This error logs seems to indicate that the database is not yet setup correctly or the user Jira is connecting to that database with does not have all the needed permissions.  I would recommend trying to follow this guide very closely:  Connecting Jira to MySQL database.

It could be that the user in MySQL does not have permissions, or it could be that some other detail of the database configuration, such as the isolation level is incorrect for Jira to be able to use this database.

Try to recreate this database per that guide.  If you're still seeing problems on startup, try looking into the $JIRAINSTALL/logs/catalina.out log file as well.  This log file can sometimes have some other information that might not make its way into the atlassian-jira.log file in the home directory.

Hi Andrew

I am getting error like Table 'jiradb.MOVED_ISSUE_KEY' doesn't exist.

When i tried to check the tables in my jiradb, it shows empty set (show tables;).

I have rechecked for creating the database and driver, all looks good to me.

Is it expected that, some default tables will be created while setting the mysql and creating database???

Thanks a lot in advance for your guidance.

When you created the database, it should be largely empty.  However once you connect this to Jira, and Jira starts up with an empty database, there are certain table that are expected to be created by the setup wizard and Jira itself. 

If the database is setup correctly per that guide, then the other concern is to learn what values currently exist in the $JIRAHOME/dbconfig.xml file.  It could be if this field has an unexpected value in it, Jira won't be able to correctly use this database as expected.   Please note this file is expected to contain your username/password for the database, you don't need to include those here to this forum, but the rest of that file I would like to see what content you have there in order to understand if maybe there is something in that file left over from when using the H2 database.

Hi Andrew, yes you are absolutely correct.

I got it resolved by removing <schema-name>PUBLIC</schema-name> line from my dbconfig.xml. I hope for MySQL DB, this line is not required.

Thanks you very much for the support

Cool, Thanks for letting us know the solution, I will add a short summary answer to this thread to clarify the answer here should other users have this same problem.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,880 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot