No such file or directory when creating new GIT repo

JIRA is running on a CentOS machine, as is GIT.

The server running JIRA can clone the GIT repo, using it's ssh keys (as the user JIRA is running as).

When I configure the JIRA GIT plugin, I set the repo using the same clone URL, and specify an empty directory on the filesystem. When I index this, I get a "No such file or directory" error message. Looking at the logs I see the below stack trace.

I have tried this on the samba share and the local disk, but both produce the same results.

As a test I even tried to set the directory to have 777 permissions.

No Googling, searching or any other tests have produced anything useful, so any additional help would be appriciated.



Stack Trace:

2013-10-18 00:29:12,880 Thread-6621 WARN jbariel 29x494797x1 1qiz9bj 81.139.72.181 /secure/StartReindexGitRepositories.jspa [jira.git.revisions.RevisionIndexer] Unable to index repository 'Test'
org.eclipse.jgit.errors.TransportException: No such file or directory
        at org.eclipse.jgit.transport.BasePackFetchConnection.doFetch(BasePackFetchConnection.java:370)
        at org.eclipse.jgit.transport.BasePackFetchConnection.fetch(BasePackFetchConnection.java:301)
        at org.eclipse.jgit.transport.BasePackFetchConnection.fetch(BasePackFetchConnection.java:291)
        at org.eclipse.jgit.transport.FetchProcess.fetchObjects(FetchProcess.java:247)
        at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:160)
        at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
        at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1108)
        at com.xiplink.jira.git.GitManagerImpl.fetch(GitManagerImpl.java:507)
        at com.xiplink.jira.git.revisions.RevisionIndexer$3.run(RevisionIndexer.java:222)
        at com.xiplink.jira.git.revisions.RevisionIndexer.runAndCollectCounters(RevisionIndexer.java:170)
        at com.xiplink.jira.git.revisions.RevisionIndexer.updateIndexByRepo(RevisionIndexer.java:247)
        at com.xiplink.jira.git.MultipleGitRepositoryManagerImpl.startReindex(MultipleGitRepositoryManagerImpl.java:265)
        at com.xiplink.jira.git.action.reindex.StartReindexGitRepositoriesAction$1.run(StartReindexGitRepositoriesAction.java:62)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: No such file or directory
        at java.io.UnixFileSystem.createFileExclusively(Native Method)
        at java.io.File.createTempFile(Unknown Source)
        at org.eclipse.jgit.internal.storage.file.ObjectDirectoryPackParser.parse(ObjectDirectoryPackParser.java:174)
        at org.eclipse.jgit.transport.PackParser.parse(PackParser.java:434)
        at org.eclipse.jgit.transport.BasePackFetchConnection.receivePack(BasePackFetchConnection.java:761)
        ... 13 more

3 answers

1 accepted

Andrey had it right, would mark correct, but was only a comment.

Must clone each repo on the server.

Jarret - we commercially support this plugin. Feel free to contact us at support@bigbrassband.com

Directory you specified in the git plugin config should contain repository clone. As for version 1.2.11 plugin doesn't run clone itself

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

90 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you