It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Newly created custom field not showing in the relevant screen by default.

Hi

Up to just a few days ago, I've created new custom fields and add them to a screen and it would show up in the create screen by default. Now however, it doesn't display by default and each user needs to select it in the "Configure Fields' box. 

This is not ideal at all because we can't go to each user and ask them to tick the new field in order to see it. Did something change in Jira?? 

I've already checked the Field Configurations settings in the admin section and the respective fields are not set to be hidden and there are no constraints on the fields.

This problem apply to any new custom field I create and/or add since yesterday.

1 answer

0 votes
Veera Atlassian Team Jan 15, 2020

@Terence_Rhoda 

The behaviour observed here is as per the current design of the create issue dialog.

In detail,

  • Initially all users get "All" Fields to show as their default setting on the "create" screen > Field Configuration. This will display all fields as per the screen configuration.
  • Screen Shot 2020-01-16 at 6.04.11 pm.png
  • Users might opt to switch to "Custom" can choose to only display a sub-set of the optional fields in the screen.
  • Mandatory fields are always displayed in the form, both if "Custom" or "All" is selected.

Consequently, when a new field is added and that field is optional JIRA does not override the user's choice of optional fields to display if they have chosen a custom set of fields already.

Users who have chosen to display all fields on the screen (via the "All" option) will see the new field.

Regardless of whether the user has chosen "All"/"Custom" if the new field is marked as "Required" in the appropriate "Field Configuration", it will be displayed. Consequently, administrators wishing for the new field to appear for every user can make the field "Required" to force this behaviour.

Hope the information here is helpful and has helped clarify the behaviour.

That is weird, because I never in the year and a bit of admining this  Jira site had to mark a new field as required in order for it to show. Even up till a few days ago as mentioned.

So if I mark it as required in the default screen scheme, does that 'Required' parameter only guide the default display of the field, or does that make the field a required field to be filled in by the user on the screen as well?

Veera Atlassian Team Jan 16, 2020

@Terence_Rhoda 

It makes the field as required to be filled n by the user as well.

Did you check if the users are using "All"/"Custom" as their default setting on the "create" screen > Field Configuration?

If they are using "Custom", you may ask them to switch it to "All" so that you don't have to make the field as required.

Ok - I just tested for the answer to my reply question and the answer is yes, and that is a problem, because it means that we'll have to make all our new field mandatory if we want it to default on an existing field or else we have to ask hundreds of users to tinker with field configs. Not practical.

I'm not convinced that this is old expected behaviour. I'm attaching proof of just a few of many custom fields that I created and it immediately showed on the screen and I never had to make them mandatory in order to appear under the ALL screen. This was the old behaviour up till a few days ago.

 

Screenshot at Jan 16 21-25-24.png

Screenshot at Jan 16 21-32-55.png

With these screen shots and your original reply, I'm now even more convinced that the behaviour changed in Jira. Please let me know if I'm missing something here as to me this looks like a potential new Jira bug.

I have a word document that graphically details the reproduction steps for this issue. Please provide an email address where I can send it to, since this text entry box does not have an option to attach documents.

 

Many thanks

Users by default get "All" Fields option until they change it to "Custom".

I wonder how the config changed to "Custom" for all those hundreds of users in the first place. AFAIK, there is no single place where you can change from "All" to "Custom" or vice versa for all users in Jira.

Veera, I'm not sure you understand my issue. 

The issue is not that they don't see the ALL. 

My problem is that the new field is not showing under ALL automatically. Previously this was the case, but now not. 

Please supply an email address for us to take this offline and I can give you more details to reproduce the issue.

We can always come back here to state the resolution.

Thanks. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you