Network Adapter error while connecting Jira 4.2 to Oracle 11G database

Got this error while trying to install Jira 4.2 and connect it to Oracle 11g database.

OS : Redhat Linux 5.5
Jira : Jira Version 4.2 Enterprise Standalone
Database : Oracle 11G R2
Java : JDK 6u37

Attempting to connect to the Oracle database server...
Could not connect to the DB: The Network Adapter could not establish the connection.

The driver oracle-jdbc-5.jar is also available.

I have oracle and Jira in the same system only. But i cant connect it. Please tell me how to solve this.

2 answers

1 accepted

Its quite clear now that the when you are running the program or script, linux is not able find it under /usr/local/bin then /bin, /usr/bin and finally in /home/myname/bin.

To add these to your PATH variable , edit the .profile file add the values and at the end, after running the $echo PATH command , the o/p should look something like -

/usr/local/bin:/bin:/usr/bin:/home/myname/bin

Hi Anandhi,

The possible reasons could be -

using the wrong URL

wrong port number or IP address

listener is not configured properly

The listener process (service) is not running. You can re-start it with the "lsnrctl start" command

Hi Naren,

I gave correct data only.

I tried the lsnrctl command. But i get a command not found error.:(

Also, i get the same 'command not found' error for ls -l command.

Please help me how to solve this....

Thanks in advance

You need to check whether your environment variables are set properlyy-
$echo ORACLE_HOME (Path to oracle home)
$echo PATH (See that '$ORACLE_HOME/bin' is in $PATH variable)

If you can't see the oracle home directories on running above commands, then you haven't set the environment variables.\
Set the environment variable -

ORACLE_HOME

ORACLE_SID

TNS_ADMIN

Example
export ORACLE_HOME=/u01/app/oracle/product/11.2.0/db_1
export ORACLE_SID=orcl

And now you can run the command 'lsnrctl start' or 'lsnrctl status' command.

Please refer this guide -

http://docs.oracle.com/cd/E11882_01/server.112/e10839/admin_ora.htm#CHDJHJGH

Hope it works finely.

I have set all those variables. I could see the values when i give echo $ORACLE_HOME etc.

But no other command is working. Like 'ls', 'su' ,'rm', 'rmdir', 'lsnrctl' etc...:(

How should i solve this..

I guess you need to check with this command $echo PATH, check whether it includes the /bin, /sbin, etc directories which contains the binaries to execute the above mentioned command.

I gave echo $PATH...and got the following output...

/data/jira/jdk1.6.0_37/bin

I set the path for java...It has overwritten the other path...what do i do now...

Thanks in advance...

I edited ./profile in /etc and when i gave echo $PATH,i got the following output.

/usr/lib64/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/sbin:/sbin:/data/jira/jdk1.6.0_37/bin:/export/home/odartadmin/bin

After this i tried giving ls -l

It is working now...Thank you very much..:):)

But still i cannot give lsnrctl command...'Command not found' error is thrown..

Please help me how to connect to oracle database...

Glad its working now :) . You can refer the 2nd comment from the top to solve this lsnrctl probelm.

You can voteup my below comment if you think it helped you ;) :)

The answer of this problem is with the PATH and ORACLE_HOME. Make sure you have correctly set these variables at the system level, or else you can repair the listener service using the Oracle Configuration Assistant

I tried starting the listener. But got this error

Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=ora11g.home.com)(PORT=1521)))
TNS-12545: Connect failed because target host or object does not exist
TNS-12560: TNS:protocol adapter error
TNS-00515: Connect failed because target host or object does not exist
Linux Error: 99: Cannot assign requested address

How should i solve this...

Thanks in advance...

Try pinging the above host name 'ora11g.home.com' by this command - ping ora11g.home.com. If its giving error like "Check the name..." then try pinging with the underlying IP address. If you are able to ping with the IP address then change the listener.ora by replacing the host name with the underlying IP adress

Thanks Naren..

I changes that hostname to my ip address and pinged it...now i am able to start the listener..

But got another problem...:(:(

ora-12505 tns listener does not know of sid

How do i solve this...

Thanks in advance..

Please check with the listener.ora, tnsnames.ora and the o/p of lsnrctl services command. Hope his solves the problem

Thanks a lot Naren...I checked these files and the hostname was a problem..Now it is solved and connected....:):):)

Thanks once again...

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,980 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot