Navigation pane greyed out and no preview view Edited

We are running Jira from our own servers and have just upgraded to 7.5.0 since the upgrade I am having issues with the Boards View.

 

The Left hand side navigation buttons are all greyed out and pulsing also when I click on a ticket in the backlog it does not show me the summary in the right hand pain anymore?

 

Other users are not having this issue, just me and it seem to be a PC or browser related issue as I can log in via my mobile device and it all displays correctlyScreenHunter 205.png 

 

2 answers

This widget could not be displayed.

Hi,

I believe that you are encountering a documented bug in Jira 7.2.x and higher versions.  This bug is currently being tracked in https://jira.atlassian.com/browse/JRASERVER-64095

At the moment, our development team is still trying to gather a more comprehensive view of the different possible causes for this kind of display error.   There is a recent note there that the 7.5.1 version of Jira is expected to be able to help gather more data on this problem.

 

In the meantime, there is a documented work-around on that page you can follow that might help prevent this display problem:

Workaround

Disable BigPipe. That will revert to pre 7.2 page rendering behaviour:

  • View Issue is going to take longer to load as big-piped panels (e.g.: Comments section, Projects Sidebar) will be rendered eagerly rather than postponed.

Steps:

  1. Navigate to http:<JIRA-base-URL>/secure/admin/SiteDarkFeatures!Default.jspa  to get to the Dark Features page.
  2. Enable the dark feature com.atlassian.jira.config.BIG_PIPE_KILLSWITCH

Please let me know if this helps.

Regards,
Andy

Thanks Andy 

I applied the fix as suggested. Ill this did was make the greyed out icons disappear it did not load anything after that.

 

I have determined that this is an issue on the PC as I have tried many other browsers but still get the same issue. I am wondering if it is a firewall and anti virus blocking issue . 

Sorry to hear this did not resolve this problem.  In this case, it would probably be best to undo this dark feature.  You can do this by returning to this page and clicking the disable button for this feature name.

Could you let me know a bit more about your environment and this recent upgrade?  Such as, what version of Jira were you running directly before going to 7.5.0?   And is your Jira instance operating behind a reverse proxy?

If you have a reverse proxy, or you aren't sure, it might help to try to follow the steps in How to bypass a Proxy and SSL to test network connectivity.   I am interested to see if you can connect directly to the Jira instance, without having the traffic redirect through a proxy to see if this makes any difference in the way the page is rendered.

Hi Andrew,
thanks for your reply. I did manage to fix this last night.
In Chrome under Settings, then under the advanced drop down tab I click on Reset and totally reset by browser.
On logging back into Jira that side bar now loading. This has fixed Chrome. I have not gotten around to IE yet

Thanks

Hi I managed to find the cause for this but not really sure why it affects the side bar 

If I enter out site using the HTTPS prefix the side tool bar does not load 

https://jira.uat.onegov....

 

However if I drop the HTTPS it loads correctly 

jira.uat.onegov.....

Interesting, it sounds like there might be a problem either with a reverse proxy in your environment or with the configuration of Jira to use that proxy.   I would be interested to check on your $JIRAINSTALL/conf/server.xml file.   This is the configuration file that determines how Jira hosts its own internal webserver (Tomcat).

It's possible to have tomcat using multiple connectors and SSL, but lots of environments instead choose to terminate SSL on a reverse proxy instead.  Jira can work in either setup, but if the connector in Jira is unaware there is a proxy, it can tend to cause weird page display issues like this.   For example if tomcat does not have a connector opening port 443 directly, then you likely need to make sure the connector being used by the proxy includes the parameters such as:

proxyName="jira.example.com"
proxyPort="443"
scheme="https"

These parameters are explained in Proxying Atlassian applications.

If you want to access Jira over both HTTP and HTTPS, I would recommend creating separate connectors in Tomcat to do this that operate on different port numbers.   This way can be helpful for testing this kind of problem.

But the fact that you found this works over http and not https is an indication that there is probably a problem with how HTTPS is configured in your environment.

This issue has come up on our instance.  When going to the link you provided to change settings, I am told I do not have permission, even though I am the site admin...

 

Please provide the next steps you would recommend. 

Hi @Peter Hagerty

Could you please clarify which link you are trying to follow steps on?   I am afraid I have listed a number of different links and addresses in the process of trying to help troubleshoot this problem in JNG's case.

Could you also let us know

  1. what version of Jira you are running now? 
  2. Did this problem just start after an upgrade?  If so, please let us know what version you upgraded from?
  3. Is this happening all the time? some of the time? or only on specific projects?

Thanks,

Andy

I had a problem following these steps:

  1. Navigate to http:<JIRA-base-URL>/secure/admin/SiteDarkFeatures!Default.jspato get to the Dark Features page.
  2. Enable the dark feature com.atlassian.jira.config.BIG_PIPE_KILLSWITCH

We are using v1001.0.0-SNAPSHOT#100079-sha1:75b11a8

I believe this issue occured when a user was using the new look and feel of Jira.  I don't have this type of issue when using the old look and feel.

The problem was resolved when resetting chrome following these steps: In Chrome under Settings, then under the advanced drop down tab I click on Reset and totally reset by browser.

Hi Peter,

Thanks for letting us know the resolution here for your instance.

In reviewing my first reply, I found a missing space that could have affected the URL.

However the other problem with you being unable to reach that page here is that the steps I posted are actually for Jira Server.  You cannot reach the dark features page of a Cloud instance.

Regards,

Andy

This widget could not be displayed.

We have the same issue on v7.9.2, it only affects firefox but google chrome is fine.

Tried the BIG_PIPE_KILL_SWITCH but it just made the icons disappear and issues remain blank.

 

Any ideas?

Hi Yusuf,

Since you're using 7.9.2, the fix for that bug report is already contained in that code base of Jira.   When this happens in your instance do your Jira logs have an entry like this found in the bug ticket JRASERVER-64095?

2017-02-14 15:57:28,689 http-nio-8080-exec-202 ERROR anonymous 6x15350x1 oclbhd 0:0:0:0:0:0:0:1 /browse/DESK-4095 [c.a.p.webresource.assembler.DefaultWebResourceAssembler] Error generating bigpipe content for 'sidebar-id': Deadline exceeded
java.lang.RuntimeException: Deadline exceeded

If not, then I don't believe that the work-around in this is still appropriate for that version.

 

It's possible that display problems like this could be caused by plugins to Jira, browser extensions, or reverse proxies in front of Jira.

  • You could try to disable the user plugins in Jira to see if you can recreate this problem.  If you're only seeing this problem with project specific types like Jira Software or Jira Service Desk, you will want to keep those plugins enabled to maintain their functionality during a test like this.
  • It also would help to recreate this problem and in the process create a HAR file to review what elements might be failing to load.
  • You could try to bypass any proxy/SSL connections to see if you can reproduce the problem that way.  This could help us understand if a proxy might be playing a factor in this problem or not.  Steps to do this are in How to bypass a Proxy and SSL to test network connectivity.
  • Another thing to check would be to try to load your browser in private / incognito mode to see if you can recreate this.   This mode typically disables any browser extensions that might be playing a factor in elements rendering on the page.

Hi Andrew,

 

We're using a proxy (ssl termination) before hitting jira, when connecting directly, indeed there's no issue.

To be accurate, it's:

load balancer / proxy (ssl termination) -> webserver with nginx, proxy to jira -> jira

From nginx to jira, using jira native 8090 port.

Server xml configured with proxyName, proxyPort and secure=true.

Guessing I need to add something extra, maybe an extra connector to somehow support firefox?

 

Thanks

Yusuf

Looks like you have narrowed the problem to the network configuration.   It sounds like you have two layers in front of Jira here, so I'm not sure that there needs to be another configuration change yet.  It's very strange that this works correctly in Chrome, but not firefox.

I would be interested to see if we can learn more about the specific elements that are failing to load here via a HAR file.   It might help to create two of these:

  1. Via the SSL connector
  2. and the other when direct connecting

With these two HAR files perhaps then we can better understand the requests being made by both browser sessions and better understand if there is something in the requested files or in the response from the webserver that might indicate why this is failing specific for Firefox here.

Thanks for leading me down the right path, upon following the create 'HAR' instructions I found a couple 403 errors, those errors were 'XSRF check failed' errors for requests to resources which I assume hold the menu.

Upon double checking the proxy settings and disabling security settings one by one I discovered setting the referrer policy explicitly to be the problem:

Nginx entry:

add_header Referrer-Policy no-referrer;

Upon commenting that out it resolved the issue in firefox!

 

I had added that header to get an A+ on securityheaders.io but I guess you guys will add it into Jira natively at some point?

 

Besides, all working at my end, thanks Andrew

fyi, "Referrer-Policy same-origin" also works, incase ppl find this in future

Awesome, thanks for sharing your solution here @Yusuf Tran

As for your question about Atlassian adding such a header in the future: I don't have an expectation that Atlassian would explicitly do this for a proxy configuration.  As you have seen, sometimes implementing higher security features can cause applications to not function the way they were designed.  Of course there has to be a balance struck for each application in its specific environment.   But proxy configuration is not something I would expect Jira itself to implement. That task does really fall more to the system administrator or the network admin.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 12 hours ago in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

39 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you