My Found In field is not being displayed

Jack Brickey Community Champion Feb 11, 2016

I have searched for this in the forum and have found similar things and indeed check the suggestions out but I haven't yet solved my issue. Basically, there is a default field (Found In) to capture the version. I want that to be a required field when creating a BUG (only). However, I'm stumbling out of the gate because I can't even get it to display at all. Here is what I have checked:

In the edit screen of an issue I have selected "Configure Fields" and "Where is My Field" entering "Found In" and it replies with all green check marks: "the "found in" field should be present on the form you are viewing". Hmmm, that sneaky field is good at hiding!

In admin/issues/customfields i have the Found In w/ Issue type(s): Bug and applicable context to Global context.

I also have the Found In set to Required in the Default Field Configuration.

Finally what is perplexing me further is that I have the "Reproducibility" field set to required for Bugs and it shows up in the create screen just fine. 

Has to be something simple but I'm not finding it.

Cheers,

jack 

1 answer

Is it in the "View Screen"? If it is, are there any versions available for selection in your Project?

Jack Brickey Community Champion Feb 11, 2016

No it is not available on the view screen either.

In your Project Screen Scheme, add that field in the View Screen.

Jack Brickey Community Champion Feb 11, 2016

I believe they exist there but maybe i'm looking in the wrong place? I have inserted a couple images to illustrate what I am looking at and assume this is what you are referring to. Thanks for you assistance!

image2016-2-11 13:21:39.png

 

image2016-2-11 13:22:33.png

 

image2016-2-11 13:23:26.png

 

image2016-2-11 13:24:40.png

Those screenshots really help. Thanks. Couple of things to check

  • Do you have available project Versions for selection?
  • In your Field Configuration, is it set to Hidden?
Jack Brickey Community Champion Feb 11, 2016

You may be on to something but a bit confused...

One of the things I tried yesterday was to actually create a version in one of my projects just to see if the field would be hidden if no versions have ever been created, but that did not resolve the issue. I agree that the issue may be related somehow to accessibility to the versions. With that out of the way, looking at Field Configurations I don't see Versions; but a bit confused since available versions wouldn't be a field so maybe i'm looking in the wrong place? The only thing i see related to versions is the field Affected Versions and Fix Versions which are autocomplete fields based on versions recorded. It is worth mentioning that I can see and select the version I create (and released) in those two fields.

You are correct. "Versions" is not exactly a custom field but a source for "version picker" type custom fields. That is why "Affected Versions" and "Fix Versions" can see your versions.

What is the custom field type of "Found In"? When was this custom field created? If it's just recently, try running a "Reindex" to the whole system.

Jack Brickey Community Champion Feb 16, 2016

sorry for delay in responding here. see screenshots below. the type is JIRA Released Version History. I never created it as it is part of the default fields. Regardless I have done a number of re-indexing as I make other changes w/o any sign of making the FI field visible.

 

image2016-2-16 20:14:40.png

image2016-2-16 20:15:5.png

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

133 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you