Move issue from project to another in scrum JIRA (web) is not doing anything. Any help?

Hi all,

I`m trying to move a story from one project to another.

For one story I suceeded. For the other stories I`m not succeeding.

It takes its time to migrate and then show a 100% migration in 0 second and does nothing.

Could you please help on that?

I`m using JIRA web (cloud) and not server.

Thanks,

Hanan

 

1 answer

Problem solved by changing the project name and key.

How?

Go to: projects-> choose your project -> go to project settings -> details -> change name and key.

I would though recommend JIRA team to generate an alaram whenever the move did not work and why. It just took me a while to understand that it is not working and how to fix it.

 

Thanks,

Hanan

Sam Hall Community Champion May 08, 2017

Hi Hanan - I'm curious. What was the problem with your old project name/key that was preventing the move from working?

I had two projects with different indexing:names and keys

Key for first project was: ACE

Key for second project was: ACE2

First time I suceeded to move one story (with its subtasks) from ACE to ACE2.

The second time I needed to do so, It showed "100% migration in 0 secs" while nothing was really changed/moved.

A similar problem was already mentioned previously in JIRA community and the reindexing solution was offered. However, it took me a lot of time to understand if the story is not moving because it is taking time or because it didn`t succeed. 

I didn`t know also how to change the indexing (in previous solution they mentiond "Project settings-> reindexing". This does not exist anymore. 

I just tried to change the name and the Key and then it fortunately worked.

 

I hope I helped you understand the problem. If you need it I can simulate what was done and send you screen shots.

Sam Hall Community Champion May 08, 2017

Hi Hanan - Thanks for posting more details.

I'm a user just like you, so was interested to know what you did. Plus it will be helpful for others in the community if they find the same problem.

For what it's worth, I think the change of project key fixed the problem for you because a side-effect of changing the key is that the project gets re-indexed.

Provided you have the JIRA Adminstrator global permission, you should have been able to simply re-index the project.

Here's a screen shot showing where that option can be found in JIRA Cloud. Do you have it?

reindex-project.png

p.s. Do you have a link to the older question in the community that helped you?

Also if you want to make a suggestion to Atlassian on improving the user experience around this, you can do so at: https://jira.atlassian.com

Thanks Sam. 

I don`t have this option

Capture.PNG

That's unusual.

I assume you do have JIRA Adminstrator permission, otherwise you wouldn't have been able to change the project key or see the 'Delete project' option.

The url for project indexing page is https://your-jira-name.atlassian.net/secure/admin/IndexProject.jspa?key=YOURPROJECTKEY if you want to try going there directly.

Might be worth raising a support ticket with Atlassian if you think you should have the option: https://support.atlassian.com/contact/

Do you have the ability to do a JIRA-wide re-index via JIRA Administration > System > Indexing (found under the 'Advanced' section)?

I think a full backgound index using that would have solved the problem as well (this doesn't lock users out, but can have some performance impact if you have many users and a large JIRA instance, so use with a little caution).

Hi Sam,

The link you posted:

https://your-jira-name.atlassian.net/secure/admin/IndexProject.jspa?key=YOURPROJECTKEY

is not working

"Oops, something went wrong

Please check Atlassian Status for known problems.
If there are no known problems and your page hasn't appeared again in 5-10 minutes then please create a support request for assistance."

I don`t even have indexing under "advanced". Thanks for your help. I will open a support ticket soon.

 

Best

 

Sam Hall Community Champion May 08, 2017

Ok. I'm assuming you changed the 'your-jira-name' and 'YOURPROJECTKEY' bits to the relevant values for your JIRA instance : )

For example if your Cloud instance is called somejira.atlassian.net and the project is ACE, then you should try:

https://somejira.atlassian.net/secure/admin/IndexProject.jspa?key=ACE

Good luck with the support ticket. If you are feeling kind, please post the outcome here as it will help others facing the same problem.

How can I change it back.

The link you put doesnt work as well :/

 

No need to change anything in JIRA.

All I'm saying is that, if you click on the JIRA URLs I gave, they won't work.

The are made up addresses for a JIRA instance that doesn't exist, just to show the pattern of the address for the project re-indexing page.

Instead, you need to copy one into your browser address bar and edit it to have the values for your JIRA, before you try to visit the page.

I just wanted to check you are doing that, because it sounded like you were just clicking them : )

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

24 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you