Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Login with a specific user only on one of nodes raises the CPU

We have a JIRA DataCenter with 3 nodes. I have an important user on it. When I login on one of this nodes leads to CPU loading near 60%! It happens just on one node and doesn't happen for two other nodes, it takes time about 10m.

1 answer

0 votes
Daniel Ebers Community Leader Nov 18, 2020

Hi Massy,

this scenario happened to me with a user that had a faulty browser plugin installed. It was requesting something from the server hundred times a second - while it should not do that.

To dig deeper it would be needed to understand how your setup is structured but even then it is hard to debug from remote.

Is there any chance you log in for a test with this specific trouble user from a different client?

In case this does not help please provide more details so somebody from here is more likely being able to help.

Cheers,
Daniel

No. I can't.

I have these logs:

08:43:15,389 DEBUG service.batch.ScheduledReportsBatchService:79 - Total subscriptions: 0, Executed subscriptions: 0
22-Nov-2020 08:44:02.440 WARNING [https-jsse-nio-8443-exec-15] com.sun.jersey.spi.container.servlet.WebComponent.filterFormParameters A servlet request, to the URI https://X.X.X.X:8443/rest/issueNav/latest/preferredSearchLayout, contains form parameters in the request body but the request body has been consumed by the servlet or a servlet filter accessing the request parameters. Only resource methods using @FormParam will work as expected. Resource methods consuming the request body by other means will not work as expected.
08:45:11,043 DEBUG app.service.CachingServiceImpl:76 - expiring 0 keys. total 0 keys
08:45:11,043 DEBUG app.service.CachingServiceImpl:78 - expired 0 keys. remaining 0 keys
08:45:24,282 DEBUG service.batch.ScheduledReportsBatchService:79 - Total subscriptions: 0, Executed subscriptions: 0
(END)

Daniel Ebers Community Leader Nov 22, 2020

From those logs nothing suspicious is to be seen.

I tried to check the problem in laboratory environment. So I made a clone of troubled instance and add it to a test JIRA data-center with a similar database and the problem happened again. I tried to test adding new instance (not clone, a new instance and new installation) to the same database but it happened again.

Now, I guess the problem is from database about third instance but I don't know what it is and how to be sure about that and how to fix it! 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you