Login and Approve button

We recently upgraded JIRA to 6.1.5 and all associated plugins; we kept our Confluence at 5.1.5 and upgraded plugins except the JIRA issues macro since it had issues. We are https and have a trusted connection between the two. Since that time, we have had issues with most JIRA/Agile gadgets.

Most would not return any information. So, we set up 2-legged oauth incoming/outbound and now have the Login and Approve buttons that appear on every gadget throughout the entire wiki. So, even if it is the same gadget, you have to click the Login and Approve button everywhere it is in use - again, not what we want because it requires a user to do this over 100 items to just show the gadgets in Confluence whereas prior to the upgrade they couldn't do this.

But, with only the trusted connection and not the oauth, we couldn't get any information from JIRA/Agile to appear in Confluence.

We did not see this in our staging environment when we tested the upgrade because this started occurring after the upgrade - it seems that the prior tokens (however they were set) expired and then today (2 weeks after the upgrade), most all gadgets stopped working which let us to the oauth setup.

Does anyone know how we get back to the state where JIRA and Agile gadgets will display their information without requiring every user to click on Login and Approve for every gadget instance?

2 answers

1 accepted

None of the workarounds mentioned in the tickets worked for us; they actually seemed to cause more issues. We ended up upgrading to 5.4.2 and that resolved our problem (we had to wait to get compatible macro versions).

Hi Karie,

I noticed that you mentioned that you're using HTTPS and your Confluence version is 5.1.5. There's a known bug when configuring HTTPS on non-standard ports in Confluence and JIRA that affects the application links:

If this is your case, you may either upgrade your Confluence to the latest version or try to apply the workaround suggested at the bug report page.

I hope it helps.

cheers

I think your problem has something to do with this issue:

https://jira.atlassian.com/browse/CONF-31993

It is odd that the issue only occurred after we upgraded our JIRA version to 6.1.5. We could not upgrade (and still cannot) upgrade our Confluence version to the current version because Adaptavist doesn't have a compatible version for their formatting plugin. But, we can evaluate if the upgrade does indeed solve our issue or if one of the other workarounds mentioned works. We did have to turn on oauth for now...but, that is a real pain because it requires the user to Login and Approve every instance of a gadget which is over 100's as we use Confluence for all of our executive/project level reporting. Atlassian's workaround of using the JIRA macro isn't acceptable because that doesn't provide the charts that execs want to see (they are much more visual) nor does it support all of the general Agile gadgets and other gadgets we use.

I'll post what we find out. Thanks!

Same for me, after upgrading to Jira 6.1.5 I run into your problem (we use a lot Created versus Resolved gadget in Confluence pages). I don't know if the Confluence version has something to do (I upgraded to v. 5.4 at the same time), but after installing the patch for the social gagdget plugin mentioned in that link and flushing all caches the gadgets worked again.

Thanks for that feedback. We'll try those options out and will let folks know what we find. Appreciate all the suggestions!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,932 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot