It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Links Hierarchy and Agile Issue


When we use Links Hierarchy we see links, but if we are in the Agile I get an error : Exception: Object doesn't support property or method getDate and lists the resource:


line: 6572

Anybody know why that is occuring and what is the fix?

8 answers

What version of Agile and browser is causing the problem?

We are using Jira 6.0.8. We do not see the issue with Chrome. It just appears with ie. We have users with ie 9 and ie10 for now.

Note I need another license for our test jira server, which I tried to get but it notices I have one already for our development server. The reason I want the license also for test is because it is using Jira 6.1.7 and JIRA Agile 6.3.7; whereas, our development Jira is using Jira 6.0.8 and Agile 6.3.7.

Note that the issue also existed with JIRA Agile, and we updated Jira Agile to 6.3.7 to see if that would help, but it did not. This looks like an ie issue.

I've just tested it (JIRA: 6.0.8, Agile: 6.3.7, Links Hierarchy: 3.4.0, IE: 9 & 10, Windows: 8) without any problem. (!?).

Are you using other plugins?

We use other plugins (DVCS Connector, Bamboo is enabled and used). Note that the issue seems to occur in an Agile board.

Thanks for the feedback. Those add-ons should not have any impact.

I've recorded the test session in a gif and it seems working nicely...(!?)

What did you use to record this session? Maybe I can get the users to make the same to show you what they see if I can have them make the same.

Sounds great, but not something I would be able to get here. Due to the snow days we just had, I have not had a chance to talk to the users to help look at this. They are all catching up on things today, so I probably will not get time with them to look at this today. I want to do a deskstop share and have them show me a little slower what they do so I can repeat it myself. Then, I could look at some kind of recording option. How do you attach things to these comments?

I used Democharge (commercial), but any screen recorder should do a similar job.

The advantage (for me) of Democharge is that it exports to animated gif format supporting annotations and it also works on any browser without requiring any video codec ;)

Animated gifs can be uploaded to the Answer portal by using the avilable icons on the tool bar. This is another advantage of gifs vs videos...

What we still find is that Chrome works fine. The user showed me again what they were seeing with IE 9 and IE10. If you go to Agile, select a board, Click on Plan, select and issue, and then under Activity click the Links Hierarchy tab, it does not do anything and keeps the tab that was previously highlighted selected (e.g., if under Activity you had Comments as the select tab option), it still remains on Comments. If the same user uses Chrome, clicking on the Links Hierarchy tab shows linked things as expected. Is there some option or something that needs to be enabled/set in the IE browser to allow IE to work? What I can do to provide you with something to help figure this out? I made a gif for you, but I do not have the ability to attach here apparently.

Clicking on the tab seems to work too:

You never click on the Link Hierarchy tab I was mentioning. You click on the little icons in between backlog and Demonstration Project. Go to Plan, click on DEMO-2, and then down in Activity, click Links Hierarchy tab. Note that I upgraded to ie11 just now and it all works with ie11 like it did with Chrome. I do not recall seeing that bar of tools between Backlog and Demonstration project that you click on. I am trying to find out if our ie9 has this vertical tool bar.

How exactly do I add my gif here?

By clicking on the upload icon: on the tool bar

and then down in Activity, click Links Hierarchy tab

I do not see the Activity!.

However, I can reproduce the error. It happens when the mouse moves over the summary of an issue without any children. It happens with IE only and it just the problem that you have reported. I will fix it ASAP. Thank you !

The test session reproducing it:

The test session repducing it:

Please, upgrade to the new 3.4.1 version, it should fix all the IE issues on Agile. Does it solve your problem?

The license expired! Do you have a way to extend it?

Remove please the current one and the trial button will become visible again

Removing did bring back trial button, but re-installing it by clicking on it put it back and it put in the old license that it found somehow.

What we see are two issues. The one showed where the red box appears with an error is one of the issues. And I am waiting on the user to tell me if they still get that error after your fix. The other error, however, we are still getting. In your demos, you click on the Link Hierachy tool in the column inbetween column 2 and 3. Do you understand? If we do that, it shows link hierarchy stuff fine in ie (even ie9).


Where you click the Links Hierarchy button and the red box appeared in your demo above. Don't. Do not click the Links Hierarchy tool there to see the second error.

Instead, on that same column, at the top click the issue number link to go into the issue. I think it is DEMO 1 at the top for you right next to the blue rocket icon. Click on DEMO 1 there.

Once you are in the ticket, you have no tool bar thing like you did in the board just prior. Instead, you have an Activity bar with things like All|Comments|Work Log|Activity|Links Hierarchy.

Clicking on Links Hierarchy here causes it to briefly look like it is going to do something with an hour glass type of thing, but returns back to the same screen with no links showing.

That is the second issue.

Note: This is not an issue with ie11 and Chrome, which is what I have on my desktop. The users have a mix of ie9 and ie10. The ie9 I know definitely is not working.

Do you have a desktop share capability? I could show you at least where I am clicking if you still do not know.

Then go please to my.atlassian.coman generate a new one from there, copy and paste it on JIRA.

Thanks, I ended up deleting the license it had in it and clicking on update. I then restarted Jira and then deleted the plugin and added it back. It then correctly provided me with a new license.

Please see my previous note on how the 2nd issue still does not work on ie9.

Sorry, I missed it from my email. Thanks for the accurate instructions, I've been able to reproduce it!. I will wait for your feedback about the issue 1 (red box) and then I'll fix this too.

The Links Hierachy tab bug has been fixed in the 3.4.2 version.

Does it work for you?

Thank you! The user who has ie9 stations has not come in yet this morning. Once she is in, I will have her try it out.

The user tested the tab, and it worked for her fine. She is now going back to regular testing of Links Hierarchy. The user for the other issue related to the red box issue never got back with me, so I am not sure what the status is on that yet. No news maybe is good news though. :)

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you