Jira with Stash: browse source without FishEye?

Hello,

I would like to use Jira together with Stash and I set up a test environment.

Stash provides a simple source browser which fulfills all my needs. But the jira source tab wants me to connect a FishEye instance.

Is there a way to browse the source of a project without FishEye? A simple link from a jira project to the stash project would satisfy me.

Thanks in advance.

4 answers

This widget could not be displayed.
Seb Ruiz Atlassian Team Oct 23, 2012

You may need to upgrade the version of the JIRA FishEye plugin you are using (now known as the JIRA FishEye/Stash plugin) to a version which supports Stash: https://marketplace.atlassian.com/plugins/com.atlassian.jirafisheyeplugin

You will also need to add an application link between JIRA and Stash.

You can read more in our docs: https://confluence.atlassian.com/display/STASH/JIRA+integration

Hello,

I'm runnng the latest versions of Stash, Jira and the FishEye-plugin. Both applications run on the same machine. Both use a shared user configuration.

I created the links between Stash and Jira and added a link from my testproject to the testrepository.

But this changed nothing: When I open the "source" tab of my testproject, I only get the info page that there is is no integration configured. There is a link to add a FishEye configuration. But I have no FishEye, only a running Stash, which already has an existing link to/from the Jira.

Where is my mistake?

This widget could not be displayed.

You might have fixed this problem, but thought to respond for anyone else who lands on this page.

I was facing the same problem. I created the trusted link both ways, and committed with Jira Issue Keys in comments but nothing happened. As per the documentation, Stash waits for the first commit with a Jira Issue Key and then indexes the entire repository. However, it did not seem to work for me.

Then I made another commit with issue keys in [], so if a issue key is "IT-567", in comments I put "[IT-567] Making changes to hello" and immediately after doing this, it showed all the commits in JIRA, and from now on, it started showing even the commits without [] in jira keys. So everything works now.

Guarav,

Indexing should have picked up your first commit; there is no special processing for JIRA keys in [], so I'm guessing it's more likely a timing issue. I can think of a few explanations for your issue:

  • Indexing happens asynchronously, so even though your commits are already visible in Stash, indexing may not have completed. If you've pushed a large history, then push a small commit, indexing will have to complete processing the large push before the small push is processed.
  • The JIRA key in your commit message wasn't recognized by the indexer. This happens when you follow the JIRA key in your commit by character that isn't a word boundary, e.g. "TEST-1234-> fixed" won't be indexed because of the trailing "->"
This widget could not be displayed.

well, I had created a new test server, and had created just one project, and one repository in it, and have just added one file so I don't see why it should take time. After app linking, I committed same file three times by making small changes, and it did not work. I waited like 15 minutes, but it did not work. And then later at the day, I used [] in keys and it worked. If it was time, then Atlassian have forgot to put in document to wait for a couple of hours before trying. I am sure the keys entered were correct because I just used the same keys all the time, and after first successful linking, all of them are being shown linked in the repo.

Guarav,

Thanks for the added information. You shouldn't have to wait a couple of hours for your issues to appear in Stash. We've even changed the JIRA indexing to always run - even when you don't have an application link to JIRA configured. Since 2.0, when you add the application link to JIRA, your issues should be displayed immediately. We made this change because it was a common source of confusion and is a nicer experience. I've now updated our documentation to reflect this.

I've created https://jira.atlassian.com/browse/STASH-3231 to track this issue. It would be greatly if you could add a comment to the issue describing what version of Stash you're using, what platform and an overview of steps to reproduce (if there are more steps than you've listed above).

This widget could not be displayed.

I added the version info. thanks.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

146 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you