It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira: user session timed out too quickly

I am trying out jira 4.4.1 in redhat 2.6.9-67.ELhugemem (32bit)

I found that my users' session are timed out after a very short time (1 min?)

How can I increase the timeout?

6 answers

1 accepted

2 votes
Answer accepted

Psst: <session-timeout> is in minutes. Your JIRA sess timeout is still 300 minutes (5 hours). [BTW, default is 30 minutes] since the application web.xml takes precedence over the server-wide settings.

Are you sure this is the problem ? It doesn't look like it ... Check the logs, please ....

Yeah, I was wondering to myself as well. Where is the log location?

I notice the adminstator login expire pretty quickly. Is there anyway to change it?

Default: JIRA_HOME/logs/atlassian-jira.log

Think there was a confusion of admin login vs normal login. Admin login session expires rather quickly, but it is not an issue.

Hi Tony.

1 minutes doesn't sound right - i think the default (standalone installation) is 60 minutes. This may be a symptom of another issue, but first you ashoudl check web.xml. Here's a link to the offcial documentation on session timeout:

in conf/web.xml it is 30

in ./atlassian-jira/WEB-INF/web.xml it is 300.

I will modify the conf/web.xml

This resolved our issue. After upgrading we realized the web.xml in the /jira/conf/ directory was only set to 30 natively, but the one ins /WEB-INF/ was set to 300. I assume the lower number will take precedence. 

Hi Pelle,

Since I logged in ticking the "Remember me" box, I remained logged in but had to reauthenticate every 10 seconds when doing any admin functions, and some form submissions had to be repeated.

In my case, the above linked article had me try the JSESSIONID -> JIRASESSIONID fix - this was the only change I made - and it solved both problems.

Hey Tony,

If this is just the admin session that needs to re-authenticate, I'm wondering if this is the websudo kicking in?:

You can disable or change the timeout if that's the case.

A quick tip for users in 2019 

If any of the installations are data center editions and on AWS, I suggest to update the following:

Update timeout in the following three places and make sure timeout number matches in all 3

1. /conf/web.xml
2. /WEB-INF/web.xml
3. Sticky session on ALB Target group(if you are using AWS infra)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

Jira Cloud for Google Sheets: Automatically Refresh Your Data!

Remember that time you realized it was possible to refresh your Jira data in Google sheets with just one click? What if we told you that you can now get the latest data with no clicks at all?! Zero! ...

7,369 views 33 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you