Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira shows ssl certificate not secure in Chrome Edited

Hi Guys, 

I have a valid certificate and Jira shows Not Secure in Chrome and Firefox.

Sometimes, when I open the Jira url the certificate show right, but after open a project or dashboard problems occour again.

Can someone help me?

not secure.PNG.png

2 answers

Hi @Fabio Manzoni ! How are you doing?

Looks like your Base URL is set to http:// instead of https://. Would you please check that?

If it is wrong, it will (as you said) work as expected as long as you do not click any link.

Hope this helps!

Hi Cristiano, 

The url is https://

htpps.png

Hi @Fabio Manzoni ! How are you doing?

In fact, I mean the Jira Base URL configuration.

To check it, just click the Cog Icon in the top bar, then System. Under General Settings you will see the Base URL property. It should be the same URL that you are using to access the application.

Hi Cristiano, 

I checked this and it's correctly. In fact this started to occur after a Chrome update. I didn't any change in my Jira Instance. 

I also have the same issue.

Navigating dashboard is okay. It show Secure.

But when opening and navigating project, it shows Not Secure.

0 votes

Hello everyone!

My name is Leonardo, I'm a Cloud support engineer at Atlassian.

I stumbled into this thread while doing some research, so I wanted to share my findings.

There does not seem to have any effective security risk. But, what happens is that when you are on an Agile board view for example, Jira is loading a non HTTPS resource in the page, which triggers that warning:
Screen Shot 2020-05-20 at 09.45.12.png

I found that when inspecting the browser console upon the page's loading. That URL takes you nowhere, it just returns a 404. If I have to make an assumption, I would say that it can be a legacy resource present in the code, or something of that sort. But that is just my assumption.

I have reported a bug to have that content reviewed: https://jira.atlassian.com/browse/JSWCLOUD-18958

Of course, I cannot give any ETA as to when someone will look into it, but at least we have our devs be aware.

Well,

I probably was hasty on this one...

I did not notice the Jira Server tags, so I don't believe my findings will apply to your case.

Apologies for the inconvenience!

Like Fabio Manzoni likes this

Thank you Leonardo, this helped me fix my issue. I was accidentally referencing a custom priority icon over http instead of https from my jira cloud instance.

I use the developer tools to discover this and fixed it.

A good tip to anyone seeing those Not Secure warnings on how to find the possible cause.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you