Jira restored but unable to login with any of the existing users

Hi Experts,

I have restored my Jira backup version (6.1.2) from one of the server to another instance, the thing is I have changed my Mailserver and his ip address which was previously being used. Now whenever I clicked on forget password while login on web interface and then error log says Could not connect to SMTP host:

 Now Please tell me where to change the SMTP address in jira configuration files.

 

Many thanks in advance

3 answers

This widget could not be displayed.

You need to check if your Jira server is able to connect to your new Mailserver ip i.e:

# linux
nc -v <NEW_IP_OR_DOMAIN> <PORT>

if you want to check how the Jira's mailserver is configured you can run the following mysql query:

select ID,NAME,SERVERNAME,DESCRIPTION,SMTP_PORT from mailserver;

On linux you can map your new ip to the SMTP domain returned by the above mysql query in /etc/hosts, then I think you will be able to receive the reset link for your password.

I am using hsql database, how to check if my new smtp is configured or not.

In the error log I can see that it is still trying to send email via old mail server ip.

and I am able to telnet on port 25 from my Jira server. 

 

Many thanks

now I have crowd server too in the same server, but still it says below error.

 

+++++++++++++++++++++++=

2018-01-22 17:54:14,338 http-bio-8080-exec-24 ERROR anonymous 1074x38x1 1rrwyl8 192.168.2.90 /rest/gadget/1.0/login [crowd.manager.application.ApplicationServiceGeneric] Directory 'Crowd Office + Ldap Server' is not functional during authentication of 'kailash'. Skipped.

 

2018-01-22 17:54:14,338 http-bio-8080-exec-24 ERROR anonymous 1074x38x1 1rrwyl8 192.168.1.1 /rest/gadget/1.0/login [jira.security.login.JiraSeraphAuthenticator] Error occurred while trying to authenticate user 'kailash'.

 

com.atlassian.crowd.exception.runtime.OperationFailedException
at com.atlassian.crowd.embedded.core.CrowdServiceImpl.convertOperationFailedException(CrowdServiceImpl.java:915)
at com.atlassian.crowd.embedded.core.CrowdServiceImpl.authenticate(CrowdServiceImpl.java:80)
at com.atlassian.crowd.embedded.core.DelegatingCrowdService.authenticate(DelegatingCrowdService.java:35)
at com.atlassian.crowd.embedded.core.FilteredCrowdServiceImpl.authenticate(FilteredCrowdServiceImpl.java:51)
at com.atlassian.jira.security.login.JiraSeraphAuthenticator.crowdServiceAuthenticate(JiraSeraphAuthenticator.java:79)
at com.atlassian.jira.security.login.JiraSeraphAuthenticator.authenticate(JiraSeraphAuthenticator.java:44)
at com.atlassian.seraph.auth.DefaultAuthenticator.login(DefaultAuthenticator.java:94) <+12> (PasswordBasedLoginFilter.java:127) (PasswordBasedLoginFilter.java:72) (BaseLoginFilter.java:131) (JiraLoginFilter.java:70) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (IteratingFilterChain.java:46) (DelegatingPluginFilter.java:66) (OAuthFilter.java:55) (DelegatingPluginFilter.java:74) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:66)
at com.atlassian.plugins.rest.module.servlet.RestSeraphFilter.doFilter(RestSeraphFilter.java:40) <+3> (DelegatingPluginFilter.java:74) (IteratingFilterChain.java:42) (DelegatingPluginFilter.java:66)
at com.atlassian.prettyurls.filter.PrettyUrlsCombinedMatchDispatcherFilter.doFilter(PrettyUrlsCombinedMatchDispatcherFilter.java:61) <+9> (DelegatingPluginFilter.java:74) (IteratingFilterChain.java:42) (ServletFilterModuleContainerFilter.java:77) (ServletFilterModuleContainerFilter.java:63) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (AbstractJohnsonFilter.java:71) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210)
at org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(RuleChain.java:176)
at org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:145)
at org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:92) <+10> (UrlRewriteFilter.java:394) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (GzipFilter.java:80) (GzipFilter.java:51) (JiraGzipFilter.java:55) (ApplicationFilterChain.java:243) (ApplicationFilterChain.java:210) (IteratingFilterChain.java:46) (DelegatingPluginFilter.java:66)

 

what could be the cause.

This widget could not be displayed.
Krisz [Adaptavist] Community Champion Jan 19, 2018

Hi there,

if nothing else works,  you could try: https://confluence.atlassian.com/jira/retrieving-the-jira-administrator-192836.html

to restore the admin user and then you can configure Jira again.

Let me know if that helps.

Thanks Krisz,

 

I tried to below steps.

I located HSQL data directory

which is /data/jira/atlassian/jira/lib/hsqldb-1.8.0.5.jar on path

then I ran below commands.

java -cp /data/jira/atlassian/jira/lib/hsqldb-1.8.0.5.jar org.hsqldb.util.DatabaseManager -user sa -url 'jdbc:hsqldb:/data/jira/var/application-data/jira/database/jiradb;shutdown=true' 

 

and I am getting below error

 

+++++++++++++++++++++++++++

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using '192.168.1.103:0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.access$200(X11GraphicsEnvironment.java:62)
at sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:178)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:142)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:186)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:82)
at java.awt.Window.init(Window.java:424)
at java.awt.Window.<init>(Window.java:477)
at java.awt.Frame.<init>(Frame.java:419)
at org.hsqldb.util.DatabaseManager.main(Unknown Source)
at org.hsqldb.util.DatabaseManager.main(Unknown Source)

+++++++++++++++++++++++

 

Please suggest

You need to be running that on a system that has a GUI installed.  Most servers do not bother, as it's usually not needed for anything.

Your options:

  • Install a GUI on the server (yuk)
  • Use a text based SQL tool
  • Copy the hsql files to a system that has a GUI and do the work there (you only need a couple of files from that directory)

Nic 

I configured GUI console but my database is not visible on prompt.

I checked my Jira instance is stopped and when I configured the exact path on URL field then it says java memory error.

 

How to reolve this

Depends on the java memory error is.  My guess is your database is too large for it to load, and you need to increase the memory for the database browser.

This widget could not be displayed.

@All..

 

My issue resolved, I changed my server with high configuration and connect HSQL database and changed admin password.

 

Many thanks guys for your support.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

169 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you