Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira issue filter contain text with partial words

On issue navigator there is a text box to filter issues. When I put an incomplete word (ie: inter) searcher show no results. There are issues with International word on subject.

Can I change the behaviour of this text box to allow incomplete word search?



9 answers

1 accepted

20 votes
Answer accepted


You can search using the CONTAINS operator. So for example:

summary ~ "inter*"



perfect! it woks wink

Like # people like this

It does need speech marks or asterisk;

summary ~ inter

Should work fine as it automatically searches using the contains operator.



This is not working for me at all....


I have a Summary field that has the text of DEF_LIST_272 Foo Bar   

I want to find my issue by looking for 272

If I use summary ~ "272*"  I get no results back

In fact , if I use 

summary ~ "DEF_LIST_*"   I still get no results back


if I use 

summary ~ "DEF_LIST_272" I get results back.


So is there a real CONTAINS feature (i.e. contains the text, like GREP does)?


I was having he same issue with a simalare keyword search. This is what i had to do to make it work. It appears it doesn't match up if it has underscores (dont think that is the only case it cant find the keyword...). So i broke it up into several phrases. Also, the '*' doesn't seem to work even thou they say to use it on their guide...

change: Summary ~ 'DEF_LIST_272'

to: Summary ~'DEF_' AND Summary ~'LIST_' AND Summary ~ '272'

This will probably return you some extra items but will also bring back the results you are looking for.

It worked well for me !! I used  summary ~ "Text"

Like Jiri Truhlar likes this

I had the same problem. The search in JIRA is sadly not that good. Wanted to search for a number in a string, e.g. test123 and couldn't find it with any option. Of course you can try like Christopher Pearson said, but you really have to know the whole string and not only a part of it.

There is an add-on called Power JQL ( from our company which can solve this problem. For your issue michael shellnutt try following jql search

for issue in powerIssue("summary", ".*272.*")

This gives the result you desire.The add-on can improve the jql search also by using  RegEx in its full potential. You can also search for attachments on issues.

I know this issue is a bit old but I ran into it myself and found this works best for me.  This only works if you have Adaptist Scriptrunner installed.  This does mean you have a dependency on Scriptrunner but it has so many useful features it's totally worth it.

This will do a partial search for 272.  It doesn't matter if the string 272 is at the beginning, middle or end.  It also allows for regular expressions.

issueFunction in issueFieldMatch("project = SM", "summary", "272")

Just noticed this does not work if you use [ ] - I get an error returned of text query '[text here]*' for field 'summary' is not valid: probably your range query is incorrect.

project = <projectname>AND issuetype = Task AND summary !~ "FT Manual testing" AND summary ~ "Manual testing"

This searches the summary and removes all the tasks that contain "FT Manual testing", if I d "Manual testing" I get all the issues that also include FT.

The only drawback with this approach is that I am relying on the summary being consistent.

sort of sad that you need always third party tools (that are quite expensive as well) to do all of these basic things :(

Hello Folks :)
Actually, noticed that if the search string contains part of the word, the search fails (does not return result).
So, I think this is a bug that Atlassian should fix.
Example :

project = "Orange Reunion" AND summary ~ "COMREQ_" ==> Does not return any result
project = "Orange Reunion" AND summary ~ "COMREQ_BUS_040" ==> returns result

Knowing that the searched case hase a summary :

"COMREQ_BUS_040 Achat Gérer des prospects - Storing shopping carts of prospect customers" without the ""


Note that you need to escape some  caracters, like the "[". Maybe because the operator "~" is base on regex?

For exemple if you want look for "[KEY]" you need to write : summary ~ "\\[KEY\\]"

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you