Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,261,543
Community Members
 
Community Events
164
Community Groups

Jira import is saying You must enter the location of an XML file

Edited

I am trying to migrate from the internal DB to MySQL. I'm on Windows. I followed the steps to backup to XML. When I try to import my data again, Jira says "You must enter the location of an XML file."

Things I've tried:

  • Full directory path: C:\Program Files\Atlassian\Application Data\JIRA\import\MigrateToMySQL.zip
  • Just the zip file name
  • Extracting the zip file and placing the two XML files in C:\Program Files\Atlassian\Application Data\JIRA\import and trying to import the XML files

No matter what I try, I keep getting "You must enter the location of an XML file."

Edit: I also managed to get locked out. Jira said that it was already setup. What can I do to get back in?

3 answers

1 accepted

0 votes
Answer accepted

Alright - so here's how I solved this. I setup Jira as a fresh install. Once I got logged in, I attempted an import using the zip I created when I backed this up. When I imported from the fresh install, I got an error that was actually helpful. A comment had a smiley in it (☺) and I had to go into the activeobjects.xml in Notepad++, delete it, re-zip the files, then importing it and it successfully uploaded. I don't know if this is a bug, but it might be. Seems a little strange I got an error completely un-related until I did a fresh install of Jira. Thanks for getting me on the right path though!

Andy Heinzer Atlassian Team Oct 30, 2018

ah,  Thanks for clarifying.  It's a known limitation that mysql databases cannot store 4-byte characters.  Hence characters like emojis can't be stored in those databases.   This is something that looks like it might get fixed in the next major version of Jira per https://jira.atlassian.com/browse/JRASERVER-36135

0 votes
Andy Heinzer Atlassian Team Oct 29, 2018

Two things I would check:

  1. Windows systems have a tendency to default themselves to hide file extensions.  If this is enabled in your system, then the file might actually have a filename such as MigrateToMySQL.zip.zip  In which case you need to enter it exactly as such to get Jira to use this.   You could confirm the true filename by going to a command prompt in this directory (cmd.exe) and the doing a dir command to see the actual filename.
  2. If that is not the case, please extract this file to make sure that it has exactly two files in it:  activeobjects.xml and entities.xml.  You won't be able to import just the xml files directly, they do need to be inside a zip file for this to work.

Yep, it only has one extension. Extracted it and the two files activeobjects.xml and entities.xml are in there. mstsc_2018-10-29_21-40-57.png

When I import the zip file, I see it go to a screen where it looks like it's extracting the files. But I've seen it disappear after a random percentage (could be 20%, could be 2% - it varies each time I do this).

I'm starting to get behind on work. Could I just setup Jira as a fresh install and then restore from the latest automated backup zips?

0 votes

Hello,

You should not unzip the MigrateToMySQL.zip file. Just write MigrateToMySQL.zip during import.

Did that. Still get “You must enter the location of an XML file.”

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you