Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira application access add/remove error

Hi!

We have a weird error in our jira's application access menu. When we try to add or remove ad-groups jira gives error with this kind of message "The page is out of date, please refresh the page.".

There is nginx proxy in front of jira application. I have tried to fix this issue with these instructions https://confluence.atlassian.com/jirakb/error-when-managing-application-access-in-jira-the-page-is-out-of-date-please-refresh-the-page-826875910.html but with no results. This problem occurs when we access jira through nginx.

3 answers

1 accepted

0 votes
Answer accepted
Thomas Deiler Community Leader Feb 02, 2018

Dear @Solita IT,

you fix it like the article has described: you turned on gzip in Jira and disabled it in nginx. Because 2 times gzip compression doesn't make sense.

Can you post the nginx configuration, please?

So long

Thomas

Actually I had a little misunderstanding with those confluence instructions. We had gzip turned on in our nginx config and jira had it off. It didn't work then but when I disabled it from nginx, it started to work. Although if gzip is turned on in jira settings does it really apply? Doesn't seem to give any response headers that it would be in use. Can't figure out what really caused it to not work with same settings. Anyway thanks for the hint!

Thomas Deiler Community Leader Feb 02, 2018

Dear @Solita IT,

sure if Jira compresses, nginx will not un-compress, just forward.

So long

Thomas

Dear @Thomas Deiler@Solita IT,

I have the same problem and i tried turn on gzip in jira, and turn off it in nginx, but nothing fix.

Please help me.

1.PNG2.PNG

Thomas Deiler Community Leader Oct 29, 2018

Dear @nordiccoder,

can you post your full configurations, please? Have you tried vice-versa? Nginx gzip ON, Jira OFF?

So long

Thomas

I has been gzip off  nginx and jira, so problem resolved.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you