Jira - Unable to import project from OnDemand to standalone

I'm attempting to migrate a project from an OnDemand instance of Jira to a standalone, local install and it's not going well.

When I attempt the import, I get the following error:

This data appears to be from an older version of JIRA. Please upgrade the data and try again. The current version of JIRA is at build number '6102', but the supplied backup file was for build number '6132'.

I'm using the latest version from the Jira downloads section (6.0.5) so...

I did read through the documentation on this, but that was no help: https://confluence.atlassian.com/display/JIRA/Migrating+from+JIRA+OnDemand+to+a+JIRA+Installed+Site

I was able to find reference to a KB article that looked like it might address this from the title, but it's been deleted: https://confluence.atlassian.com/display/ONDEMANDKB/JIRA+OnDemand+export+does+not+import+into+standalone+JIRA

Any help?

11 answers

0 votes
Timothy Chin Community Champion Jul 23, 2013

What you should do is to import the OnDemand to the same version as your production instance first. Setup a test instance, import the OnDemand there then do a project import.

OnDemand is always a version ahead of download distributions, so this is impossible.

Actually, no, you are wrong. It works within certain ranges. Try exporting from OD, and importing on the version od-1 or od-2. You get a huge great warning about losses of functionality, bit the import works. Lower I've tried it with is a target of 6.1 from od6.3, bit it is working

It works within a range, yes, but you cannot just "import OnDemand to the same version as your production instance" because there is no way to have a local version on the same version as OnDemand (unless there is a download area I'm unaware of... happy to be wrong about this!).

I've encountered OPs XML error after skipping updates for a couple weeks on my local instance. I had to update my local instance to the latest from the download site to be compatible with my OnDemand backup (and then I get the expected functionality warning you mention).

I think you're missing the point - if OnDemand is using the version called OD-6.3, and your production version is plain 6.2 (which means "download 6.2"), you can import the data. You don't need the same version as OnDemand, just a close-ish one.

I apologize for any misunderstanding, but I think we're agreeing at this point.

OP's issue is an error from the compatibility check when importing an OnDemand backup into a Jira download version.

The fix (at least in my case, when I run into this) is to install the latest download version (a version behind OnDemand, but compatible with ondemand backups).

The advice given in the answer I commented on, "import the OnDemand to the same version as your production instance", is literally impossible and causes confusion.

Unfortunately in the case of the original issue, his install and OnDemand at the time should be compatible (according to this page: https://confluence.atlassian.com/display/JIRAKB/JIRA+Build+and+Version+Numbers+Reference)

That being the case, this is more likely an issue that only Atlassian Support could help with.

not following... the OnDemand version seems to be newer than the latest version that's available for download. I don't know how to make the versions match

Are importing from a database backup file or from a XML file? If it is the XML file, I would try changing the build number in the XML file to download build number.

Norman:

I'm importing a .zip file backup... not sure what or where to change the build number?

If you look inside the zip file, I believe you will see some files named entities.xml and activeobjects.xml. I would look in these files for the build number and change it. If you are unfamilar with zip or xml files, find someone in your organization that does to help you make these changes.

Steps to Follow

1) copy zip file to another name like do_not_touch_me_in_case_i_mess_up.zip.
Also make sure this is a binary copy.
2) Unzip your original zip file
3) Edit *.xml files and change the build number
4) Rebuild your zip file
5) Import the rebuilt zip file

You have one more option. You can contact Atlassian support and see if they would 'fix' your backup file.

We have the same problem: ondemand version 6134 (6.1 OD 4), Onsite Version 6105 (6.1), which is the last downloadable stable version.

We're trying to import just a project into our internal Jira, that has already several other projects. Changing the build number has not effect.

It would be helpful if Atlassian could reply to this!

Same problem here. Anyone have a working solution (that they've tested - not just *think* should work)?

Having the same problem here as well. Atlassian does not seem to be responsive to these questions. I am opening a Support ticket.

did anyone succeed in getting the problem resolved?

0 votes

Later versions of downloaded Jira allow you to skip the build check.

If you export from OnDemand now (which is on 6.2), and download 6.1, you'll get a warning, but it will import the backup file without you having to change anything.

this works of course, but only for the whole backup to be restored in either a fresh Jira installation or overwriting all existing data. What I want to do is importing the projects into an existing Jira installation, while keeping all projects in this installation.

Seems like there is no other way than to create a temp Jira installation import the backup and backup it with this version, so that I can re-import the single projects.

That is correct - project import has always required the data versions to be the same.

More than one year later I think this is still not solved.

I have a fresh v.6.3.15 JIRA installation (last version downloadable) where I want to move some projects from JIRA oncloud, but there is no way. I've just taken an export from the cloud, and created another zip file containing only XML files as you said here. When I try to import the file I get this message:

The current version of JIRA is at build number '6346', but the supplied backup file was for build number '64012'.

Is there any solution for this? or will I have to keep my projects on the cloud forever?

I'm gonna try other solutions like modifying the contents of the XML files, but I think this shouldn't be the way.

I think Atlassian should inform about these kind of things before deciding to move oncloud... something like "think twice, if you go oncloud, you will never be able to go onpremise, .. and if you get it, it won't be easy at all!".

Thanks in advance, 

If you find a solution for this that would be great. I am running into the same problem

64012 seems to be EAP release 6.4 m14. So I could install that but I really want to install a production version not an early release item......

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

25,567 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you