It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Server for Slack notifications bug Edited

Hello there,

We have been using your Slack official plugin since the very beginning, but we have discovered a strange bug that affects some of the last issues.
We have a project, like many others, with a specific alert notification (specifying issue type and transition status). The alerts have been notified correctly until mid December, but the more strange behavior is that there is one correct notification in the middle of seven fails.
I have already tried to investigate the logs with the debugging mode suggested in one of your documentation, but I cannot find the problem.
Moreover, if I trigger the rule again, it seems that it notify correctly for all the issues that have already worked before, and does not work for the seven issues that has already failed. It seems something related to the specific issue instead of the project settings, but these issues have not changed since ages.
I attach you a couple of screenshots that I hope will help you during the investigation.

Environment:
Jira version v7.11.1 (we will refactor the server this spring, switching to the new LTS).
Jira Server for Slack v2.0.6

Logs:
As you can see from the logs, PROD2019-153 properly triggers the notification while PROD2019-173 does not.
The main difference I see is this message at 2020-01-15 16:25:21,844 "Finding Configurations for event [ISSUE_TRANSITIONED] : 1". While in the other case the transition seems not to be detected.

If you have any suggestions, please let me know.

Best regards,
Alessandro Tondo

1 answer

1 accepted

1 vote
Answer accepted

Hello @Alessandro Tondo !

I am from support team for Jira Server Slack plugin. One of the possible reasons of the issue you observe is that status isn't changed during transition of the bad issue. Could you verify that in the issue change log?

Also, please create a ticket at https://getsupport.atlassian.com/ for more detailed investigation of the issue.

Hello @Mykhailo Vlasov ,

Apologize for the late reply, but I didn't see the notification before.

As you can see from the attached log, there is a subsequent transition from Closed to In Stock and then back to Closed.

There is already an unresolved ticket opened: https://getsupport.atlassian.com/servicedesk/customer/portal/35/CA-893617.

Thank you for your time!

The issue should be fixed in the recent version of the plugin - 2.0.7. Please upgrade to version 2.0.7 and let us know if your issue is fixed for your case.

Like Alessandro Tondo likes this

@Mykhailo Vlasov it seems that the problem has bumped again in version 2.0.11 and 2.0.13. Can you please check if it has been accidentally reintroduced in these last versions?

Thanks for your help

@Alessandro Tondo The plugin was open sourced recently. Its sourced and all known bugs are tracked in Github repo: https://github.com/atlassian-labs/atlassian-slack-integration-server/issues. Would you mind creating an issue there with detailed description of it? I would be interested the most in your JQL query, that may not match an issue the way it is expected.

Like Alessandro Tondo likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you