Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Jira Excel Integration: Login error

I have used the Jira plugin for excel many times in the past, however today I encountered an unexpected error. When I click "get started" to grant access to Jira, I am given the following error:

You don't have an Atlassian Jira & User identity site to connect Jira Cloud for Spreadsheets to. Visit to create a site.

Something's not right? Raise a support request.


Does anyone know how to resolve this? I'd love to be able to pull reports of issues into an excel doc like I did in the past.

6 answers

2 accepted

1 vote
Answer accepted
Levente Szabo _Midori_
Marketplace Partner
Marketplace Partners provide apps and integrations available on the Atlassian Marketplace that extend the power of Atlassian products.
Nov 19, 2021

Hi @lesya.zaichenko 

Jira Cloud for Excel has these intermittent, cryptic glitches that sometimes just go away on their own. How long has this been the case? Did you try reconnecting your add-in to Jira Cloud? I collected a few cases of Jira Cloud for Excel errors and how to handle them, but there is really not much you can do other than the usual (disable, enable, reconnect, re-install, wait, etc).

Hi @Levente Szabo _Midori_ Thank you for your help! I have uninstalled and reinstalled my Jira add-in for Excel, rebooted my machine, etc. Unfortunately this issue is persisting throughout the day and over the course of multiple days.

Screen Shot 2021-11-19 at 9.43.18 AM.png

Like Dustin Davis likes this

Hi, how did you remove this problem ? 

Thank you

I haven't been able to resolve this problem yet. :( It's a major bummer.

0 votes
Answer accepted
Aron Gombas _Midori_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Nov 19, 2021

Have you tried to reconnect to your Jira instance?

(I could imagine that the Excel plugin's session expired in the background and all you have to do is re-authenticating to Jira.)

Hi @Aron Gombas _Midori_  thank you for you response! The core issue is that I am unable to connect to my Jira instance entirely. I've removed and then freshly installed the Jira add-in for Excel, tried exporting a new issues report to excel, and encounter the same issue each time. I pasted a screenshot of the error in my response to the other answer above.

0 votes
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Sep 03, 2023

I had the same problem and have been able to resolve it by performing the following steps. The issue for me was that I had access to 2 Jira instances and it did not know which one I wanted to sign into.

1. When clicking Connect to Jira it redirects to a screen to type in a 6 digit code.

2. Copy the url of this page into an Incognito Chrome Window

3. The Incognito window will force a sign on. I am then able to select which Jira instance I want to log into and then sign on using my standard work email log in.


Hope this helps.

This is SICK I got exactly the same problem to connect by oauth to my custom app, we have jira premium and they just leave this absolutely critical bug and I waste so much time because of their incompetence. It drive me crazy.

I have the same issue and haven't resolved it.

We have kind of a similar problem after enabling allowlist on our cloud instance of Jira. If the list is disabled, Excel add-in works, if it is enabled it does not, despite the fact that the IP of the person's computer who is running Excel in on the list.

Suggest an answer

Log in or Sign up to answer